0

I have a VServer with OpenSuse 11 and Plesk runnning. Right now the server runs a php website. I would like also to run a Rails-Application with mod_rails (phusioin passenger).

I have installed ruby and rails and also I am trying to get phusion passenger to run on my appache 2 which is not working as I wish it would.

What I did was running following commands:

gem install passenger

passenger-install-apache2-module

After I ran the second command the installer tells me that I am missing

  • Apache 2 development headers
  • Apache portable headers (APR)
  • Apache portable runtime utility development headers (APU)

After some investigation I found that my solution could be to install following packages

httpd-devel
apr-devel

OpenSuse 11 has zypper and this does not contain these packages. I ran into an article which discribes to install these packages with yum. But yum is not compatible with the python version of my linux distr.

I also saw that it is possible to download the source of apache and compile it with the correct headers but since this vserver has a running site. New installation or compiling is not an option.

So how do I get my prerequisites installed to make passenger install and run on my server?

Any help would be great (and bear with me I'm new with linux)...

Regards

0

If you have yast you could try using that:

yast -i apache2-devel

1

Yast is your friend here. I've actually been able to install all the missing things that passenger-install-apache2-module moans about (on openSUSE) just from Yast.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.