1

I've a VPS and although I am not a systems analyst by profession, I'm pretty used to configuring remote vps/dedicated boxes. Configuration: CentOS 5.4, lighttpd 1.4.22, mysql.

There are 7 domains configured with simple_vhost module. All of them works well, except one.

This domain works well only with www, but not without. I've configured "A records" for @ and www, pointing to my ip (as other hundreds of times)... wait for the propagation, etc. Now the problem seems to me pretty strange: without www I receive a port forward to port 81. Why? Why?

I've tried to disable iptables, pointing the domain elsewhere, but nothing. Only one domain. I think it is not possible that this can be a DNS service (thirt part service) problem.

Here is an excerpt of the lighttpd configuration file:

http://www.heypasteit.com/clip/LAM

I'm about to tear all my hair!

Thank you!

1

Lighttpd shouldn't be doing any port forwarding unless you have explicitly told it to (especially if all your other sites are running as normal on port 80). DNS can't redirect to another port, it simply doesn't have the ability to. Which leaves either the dns hasn't propagated properly yet or the site software itself. Have you ever used port 81 for this or any other site?

It sounds to me like dns hasn't fully updated and whatever is doing the port forwarding is still running on the old ip address. Or perhaps you've had an entry in your /etc/hosts for this site at one point and never removed it?

  • In the old address, the port was always 80, DNS propagation is already complete, I tried various checker and I also asked some friends, and even from my location is ok, /etc/host contains only the main host. Ok for "site software" but if I do a simple redirect or whatever, the problem still here. And after having stopped stop lighttpd there is no forward to 81!Some lighttpd configuration files unknown to me? All this seems crazy! – LEv Jul 10 '10 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy