I have two ESXi servers, both updated with the latest patches through the Host Update Utility. One of the ESXi servers is a new install, other was around for about 8 months without any problems arising. All VMs are ESXi native, created on the old server (I have serveral Windows 2003 and Arch Linux VMs). After installing ESXi on the new server and updating both servers, I tried moving VMs from the old one. However, the job fails every time with the status:

FAILED: The operation is not supported on the object.

However, I am still able to convert ESXi VM to the VMware Server VM (it's installed on my own workstation). I have necessary sysprep files in the Converter directory, both hypervisors and the Converter are the latest versions available... What's wrong? What should I do to be able to move VMs between ESXi servers?

UPD: Converter also worked in the past (about 4 months ago), while I templorarily installed ESXi on a whitebox to test whether conversion works at all.

5 Answers 5


Why not export the VM's as virtual appliances on the source host and import them on the destination host? That's the way I move VM's around and it works like a charm. (Of course I'm a complete VMware neophyte).

  • It works, but the Converter is supposed to work in a different way - and it doesn't.
    – Seishun
    Jul 14, 2010 at 6:43
  • +1: I'm not a VMware neophyte and this is my preferred method (on systems that aren't "fully" licensed; those go on the vCenter and just get cloned). Using ovftool you can deploy the exported files with thin disks too. Aug 23, 2010 at 15:28

This error is a bit misleading, it (usually) refers to a problem with the virtual devices you've assigned to the machine.

When you run through the converter wizard, how far are you getting before it fails? I suspect you've got all the way through the wizard, can inspect the source, can browse the target, and are back at the job screen when it tanks?

Try disabling any kind of customization of the VM, in the wizard, on the last page.

Check the devices you have assigned to the virtual machine, and remove everything but the bare min. Check that your defined VLAN networks are available on both ESXi machines and are labelled the same.

Are you using the latest version of Converter? (4.0.1)

  • Yes, the Converter version is the latest one, and the ESXi servers are both updated with latest patches. I am able to fully set up the task, the Converter starts working on it but then throws the FAILED status. I am not enabling any customization on the last page of the wizard. In fact, the devices are already reduced to the basic minimum, but I will try your suggestion about VLAN labelling.
    – Seishun
    Jul 14, 2010 at 6:42
  • +1 my guess is the VLAN labeling Aug 23, 2010 at 15:30

Are you just trying to move the VM from one server to the other to have them run on a different server? I would look at just copying the VM's configuration and drive files over with the storage managing utility (maybe using a shared storage directory as an in-between). It'll take awhile, especially if the files are large, but then you can just tell the new server to create VM's based on those drive files (pre-existing). As long as the versions are matched, this should work just fine.

  • Riight, I can just move the files and re-create the VM on the new server (which I actually did for one VM), but the reason I ask is that I want to use the Converter. It's the official way to move VMs, and I cannot understand why doesn't it work for me :-(
    – Seishun
    Jul 12, 2010 at 13:03

Are you trying to do some kind of hot copy, or are you shutting down the VMs before taking the image?

I think the converter may work best on machines that are shutdown, so it isn't having to snapshot memroy etc. Also, check any snapshots you might have of those VMs. That may make the process more complex. It is possible that converting to VMWare Server is working as it isn't trying to convert any ESXi specific features.

  • All VMs are offline when I'm trying to "convert" them. I don't use snapshots (or any backup software that relies on snapshots either). And - simply moving the VM files and configuring it on the new server works (though it doesn't have the right feeling to it :-)
    – Seishun
    Jul 12, 2010 at 13:57
  • I agree - and I spoke to VMware about it (we have ESX so pay for support) and they recommended using Converter. Are you using the standalone converter (i.e. not one integrated into VMware Infrastructure/vSphere Client)? I think you probably need to dig deeper into the logs - that would be easier with ESX than ESXi, but I am sure it is still possible.
    – dunxd
    Jul 17, 2010 at 14:47

When I have VMs that I can not move across ESX servers, I am using netcat to transfer the VM content over network.

Here are the steps I am using for this:

  • Create a new VM on the destination with the same configuration as the source (especially the disk size and layout)
  • Boot the source and destination VMs from a rescue Linux (a CD/DVD, or from a PXE server)
  • on the destination I run: nc -l 10000 > /dev/sda where 10000 is the port
  • on the source I run: nc destination_ip 10000 < /dev/sda where destination_ip is the IP address of the destination inside the rescue Linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.