I'm installing a TFS2010 with Reporting Services (SQL Server 2008) but I'm getting an error, below are the details and steps I did:

I'm installing with a domain account who is also a local administrator, the box is a Windows Server 2008 R2.

I installed Reporting Services in the box (no database engine nor Analysis Services), in the setup I choose "Install, but do not configure the report server", everything installs OK, then apply SP1 of SQL Server, everything installs OK again.

Then open the configuration manager, in the Log On screen I choose the local server and the default instance and I can connect successfully.

The services account is network service.

In the Web service URL" tab I click apply.

Then in the "Database" Tab I click create database, then select create new server database and here is where my problems start.

I cannot log on to the server with the current user, I already tried changing the service account from "network service" to the current account but that did not help, the error I get is this:

Could not connect to server: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

Shared Memory, TCP/IP and Named Pies are enabled, I tried to create an alias (tcp, port 80) but I still cant connect to the server, I also cannot connect to the server with Management Studio because I get an error saying that the server is not configured.

Does anyone know what I have to do?

Thanks in advanced.

Juan Zamudio

1 Answer 1


I edited the answer and not remember what i said, it was something about needing Report Server locally.I was wrong, the server i was choosing was not configured correctly.

  • No, you can use a remote database engine providing you aren't using Express edition and that permissions are assigned correctly. Jul 19, 2010 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.