The task which I want to run runs fine manually. But when I set a time for it to run using "Scheduled Tasks", it doesn't run.

What may be causing the problem? How do I fix it?

  • does it display a gui interface? – tony roth Jul 15 '10 at 18:38
  • it displays nothing – l--''''''---------'''''''''''' Jul 15 '10 at 18:40
  • 2
    check the log file (from memory, in scheduled tasks go to the menu bar and choose 'Advanced', then 'View Log'. Do you get any clue as to why it does not run? Check the event log as well – natxo asenjo Jul 15 '10 at 18:58
  • @natxoasenjo, The log doesn't log anything for my scheduled task. – Pacerier Feb 3 '15 at 8:53

Double check the scheduled time/date that it runs, along with the user credentials it runs under. Also make sure the current/date time is set correctly.

| improve this answer | |

On the Scheduled Task's property screen, do you have the 'Run only if logged on' checkbox checked? Is the Enabled checkbox checked?

| improve this answer | |

The scheduled task will not run if it hasn't completed its previous run.

So, ensure that your scheduled tasks are not running longer than the interval set.

To stop your current running task you can Right ClickEnd Task:

enter image description here

Also, use schtasks /query /v /fo list for a detailed view of the "state" of your scheduled tasks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.