5

I am attempting to enable web-management functionality on my Dell PowerConnect2824.

From what I can tell by reading the manual I need to connect via the serial port to enable web functionality.

I picked up a serial-to-USB adaptor and installed the drivers onto my Windows 7 machine. It now shows up in my Device Manager under Ports, Prolific USB-to-Serial Comm Port (COM5).

However when I fire up PuTTY and choose 'serial' and enter COM5 the resulting terminal window simply hangs.

The PowerConnect uses VT100 protocol which from what I understand PuTTY recognizes. My serial settings are as follows:

Serial: COM5
Speed: 9600
Data bits: 8
Stop bits: 1
Parity: None
Flow control: XON/XOFF

5 Answers 5

9

Most switches that I have worked with do not use any flow control, so I double checked the Dell PowerConnect and it indeed does not use flow control.

From page 33 of the manual: 9600 baud 8 data bits, 1 stop bit, and no parity Set flow control to none Under Properties, select VT100 for Emulation mode

1
  • 4
    +1 flow control is probably the problem... also 8N1 is pretty much standard for switches ... except for some low end biz models (i'm looking at you linksys!)
    – Zypher
    Jul 17, 2010 at 3:01
3

Try pressing Enter after connecting. As far as I know, there's no way for the device to know when PuTTY opens the serial port; an Enter keypress would serve as a "attention" message and you should receive a reply.

0

This sounds stupid, but did you make sure that your serial to USB cable is also a null-modem cable?

I've had the same issue, until I figured out that I had to get a small null-modem bridge in order to actually communicate with a server with a serial console.

2
  • 3
    I can highly recommend making or getting some Yost adaptors and using the suggested cable type. They make life so much simpler if you're using serial much. Serial should be burned at the stake. Jul 16, 2010 at 23:44
  • Hmm, the package makes no mention of a 'null-modem' or 'crossover' cable, and I am using the cable supplied with the switch which makes no mention either, I will pick up a null-modem cable and see if that is the issue. Thanks.
    – user30875
    Jul 17, 2010 at 1:23
0

You probably need to read the switch's manual to see what serial options need to be set for Flow Control, Parity, etc. It should be in there somewhere.

0

Late answer but maybe it helps future readers:

I had the same problem: powering up an new switch and attaching the serial management cable with a USB/Serial adapter didn't give me any output.

The cause turn out to be that after the switch powered up, there was no data output from the (new) switch. The trick was to attach the serial adapter before booting up the switch.

The putty settings were (as described in the manual):

Serial-Settings:
* Serial: COMX (in my setup COM5)
* Speed: 9600
* Data bits: 8
* Stop bits: 1
* Parity: None
* Flow control: None

Terminial/Keyboard Settings:
* Funktion keys and keypad: VT100+

The flow control could be set to XON/XOFF and the Funktion keys and keypad to ESC as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.