I'm currently maintaining git packages manually for my CentOS machines since there seem to be no recent packages available in the Repos. I'm rebuilding the SRPMS from kernel.org, but --without docs since I can't satisfy the dependencies, which is not pleasant.

A recent query on the mailing list yielded a single result - a personal repository, which is not enough for me.


webtatic appears to have a repo with version as of this posting.


The ultimate repository is Dag Wieers'. He has been building RPMs for thousands of projects for some time now, and is one of the first things I add to my repos.d dir. It was rebranded as RPMForge a couple of years ago, which involved merging with a couple of other widely-respected repositories.

He has Git rpms in there.

  • Thanks for the answer. Those RPMs are quite old, in the 1.5.x range. I'll looking for up-to-date ones, in the 1.6.x - preferrably 1.6.3 - range. – Robert Munteanu May 31 '09 at 14:43
  • As of June 2010 or so, RPMforge has had very recent versions of git. – Philip Durbin Nov 2 '10 at 13:44

I ran into this same problem. The way I solved it was by following the INSTALL instructions in Near the bottom, it explains how to grab a copy of the pre-formatted documentation. It's pre-built, and you can get it once you've installed git. The commands are as follows:

$ mkdir manual && cd manual
$ git init
$ git fetch-pack git://git.kernel.org/pub/scm/git/git.git man html |
  while read a b
    echo $a >.git/$b
$ cp .git/refs/heads/man .git/refs/heads/master
$ git checkout

I actually needed another command:

git reset --hard

...but after that, it worked like a charm. I just added that directory to my $MANPATH in my ~/.bashrc like this:

# git man pages
export MANPATH="$HOME/local/git-manual:$MANPATH"

...and all the man pages work as expected. I am so happy that I got this after upgrading! Hope it works for you too...


How recent? EPEL has http://download.fedora.redhat.com/pub/epel/5/x86_64/repoview/git.html

  • Thanks for the answer. I'm looking for up-to-date ones, in the 1.6.x - preferrably 1.6.3 - range. – Robert Munteanu Jun 1 '09 at 19:25

Given how greatly you value having recent package versions, Centos probably isn't the distro you're looking for. Even Fedora Rawhide does not have git 1.6.3, largely owing to the fact that it was just released 2 weeks ago. I did find it in the Gentoo ~arch tree, as well as an ebuild that will build off the current git HEAD.

  • There’s a slight difference between valuing having recent package versions and not wanting to use packages that are 6 years old or worse. – Olivier 'Ölbaum' Scherler Nov 27 '12 at 11:20

You can get the latest Git RPMs directly from kernel.org. However, you might run into library dependency issues on CentOS, due to older versions of dev libraries available there. The last time I looked into Git on CentOS 5.x, the latest version I could reliably install from RPM was Newer versions, you're probably better off compiling the SRPMs, or compiling the Git source directly.

  • Thanks for the answer. As my questions says, I'm rebuilding the SRPMS from kernel.org, but --without docs since I can't satisfy the dependencies. I'm looking for a proper repo for them. – Robert Munteanu Jun 1 '09 at 6:29
  • I'd venture to guess there isn't a public repo of newer Git versions. RHEL/CentOS 5 is getting long in the teeth, and to stay current with a lot of software you'll need to roll your own anyway. I would certainly automate the build process and post the RPMs on a local yum repository. – jtimberman Jun 1 '09 at 13:19
  • Not my ideal answer, but this is the harsh reality. Thanks. – Robert Munteanu Jun 11 '09 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.