I'm trying to create shadow copies of 10TB volumes but am having no luck. I've gone down dozens of paths based on the errors (most of them very vague and/or misleading) and the only true correlation to success or failure I can find is with volume size. I've got 8x 10TB volumes, and none of them will create a shadow copy -- either onto their own volumes or onto separate volumes.

It's not a disk/storage space issue, as a brand new volume with no data will still not create a shadow copy. These are all iSCSI volumes, but that appears to also be a non-issue, as I created a 250GB volume for testing and VSS works properly on that volume. I also tried creating a shadow copy of a 6TB volume onto a 10TB volume, so it clearly has nothing to do with available storage. I created a 10TB volume and continuously reduced the size thereof until a shadow copy worked, and it turned out that it breaks when the volume reaches just around 4.5TB.

Unfortunately, these 10TB volumes are all in use and full of users/data, so it's not an option to start all over with 4.5TB volumes.

Anyway, I've verified that all components of VSS are working and all patches are in place (and it's easily confirmed by kicking off a shadow copy on the 250GB or 4.5TB volume whenever there's any doubt). The actual error received is "Failed to create a shadow copy of volume ... Error 0x8007000e: Not enough storage is available to complete this operation." That's another misleading error, however, because the test volume is entirely empty. Many resources also say that error indicates a memory issue, but again, that can't be the case as it always kicks off on the 4.5TB volume (and I also tried it immediately after a restart with identical results).

Can anyone confirm that a) there's a hard limit on volume size or b) they've successfully created shadow copies of volumes larger than 4.5TB using Server 2k3R2 SP2 x86?


This Technet article on VSS scalability indicates that the issue probably relates to exhaustion of the nonpaged memory pool which is limited to 256MB on Windows 2003 32bit (x86). VSS uses more resources during snapshot creation and the article specifically states that a 5TB snapshot would require 200MB for that snapshot alone. Depending on what else is making demands on the non-paged pool it seems likely that you are hitting that limit.

For what it's worth 64bit systems have a much larger nonpaged pool and would not suffer in the same way.

The "not enough storage" error generally indicates exhaustion of system resources like the non-paged pool or heap exhaustion in my experience and does not typically refer to either disk or general memory.

  • Thanks for the info. Short of adding memory to the machine I could only try creating shadow copies immediately after its last reboot in the hope that there'd be enough nonpaged pool available, but I had no success with that. – Uninspired Jul 20 '10 at 16:55
  • 1
    Adding memory to the machine is unlikely to help unless you have configured the machine with less than 1GB of RAM - the non-paged pool maxes out at 256Meg on when total system memory is more than about 1GB (unless us use the /3GB boot switch when it's actually limited to 128Meg which would make your problem a lot worse). The only way to significantly exceed the limit you are experiencing is to move to a 64bit Windows version. There's some excellent info on the Non-Paged pool in this article by Mark Russinovich : blogs.technet.com/b/markrussinovich/archive/2009/03/26/… – Helvick Jul 22 '10 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.