The first part of the stack-trace is as follows: "UnsatisfiedLinkError (/usr/lib/jvm/java-1.5.0-sun- libmlib_image.so: cannot open shared object file: No such file or directory):"

Both libawt.so and libmlib_image.so exist and are in the same directory. Does libawt.so look in a different directory? Is there an environment option I'm missing?

This is part of a Rails application using Rjb (ruby-java bridge).

Any help is much appreciated.


You may need xorg-libs installed on your host. Also you could try to launch the process using -Dawtheadless=true and see what the result is.

  • -Dawtheadless=true (actually, -Djava.awt.headless=true) was already used as an option. Tried -Dawt.headless, -Dawtheadless, and -Djava.awtheadless with the same result. Also installed xorg-libs with no luck. – user48862 Jul 21 '10 at 1:58

I've seen this before. I believe it was actually a bug in the 1.5 JDK. With some digging you can find the report.

If I recall correctly, the fix was something along the lines of setting the LD_LIBRARY_PATH likes this:


I hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy