1

I can access and read a Samba folder from Windows 7. I've been following some sites instructions:

My Windows 7 is configured like told below:

http://www.tomshardware.com/forum/75-63-windows-samba-issue http://www.linuxquestions.org/questions/linux-server-73/windows-7-beta-1-and-samba-696990/

And my smb.conf has a shared folder, configured for do not require authentication, as the following site says so:

http://ubuntuforums.org/showthread.php?t=658056

I also tried the following:

chmod -R 775 sharedfolder
chown -R someuser:somegroup sharedfolder
in smb.conf :
   create mask = 0775

But I still get the message that I have no permission to write.

  • Just checkin' up on some of my older answers... Did you ever get this going? – Evan Anderson Jul 22 '09 at 6:59
  • I couldn't make it work. I gave up and now I'm with Windows XP. – Jader Dias Jul 23 '09 at 14:26
2

I'm using Windows 7 to write to shared folders on a Samba 3.0.28 server running on CentOS 5.2 with no problems. It would be helpful if you could post your smb.conf file (or, at the very least, the global section and the section relating to the particular folder you're asking about).

The link to UbuntuForums.org that you posted shows an example config with "writable = no" in it. I'm assuming you haven't got that set on the folder in your smb.conf.

  • I couldn't make it work. I gave up Windows 7 and now I'm with Windows XP. – Jader Dias Jul 23 '09 at 14:25
0

Hmmm... -r or -R? What OS/distro is Samba running on?

0

I had not-quite-the-same issue with Windows Vista and Windows 7 writing to a Windows share on Mac OS X. The fix was for me to change a local policy to enable compatibility with an older version of NTLM.

Here is the link

[Edit: I didn't read the links from OP, so if you want to ignore me, feel free :)]

0

Windows 7 allows you to map a drive letter through FTP. I would just abandon the Samba thing and go with that instead. If you run a Putty.exe tunnel you could even encrypt the connection through the SSH port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.