I am a network administrator at a small company that uses Network Load Balancing (NLB) to cluster our terminal servers together. Recently, we changed our network setup due to PCI-DSS compliance. Because of this, we introduced a Terminal Service Gateway to secure traffic going to the terminal server cluster. Ever since that change has occured, our NLB cluster is not distributing traffic anywhere near evenly between the hosts. What happens is that one host will take almost all of the incoming traffic until it is stopped or drainstopped. We have set the load weights on each server in order to try to alleviate the problem, but to no avail. We are totally out of ideas. Any help would be greatly appreciated. Thank you.


Can it be the TS cluster sees exactly ONE host where the traffic originates from (the gateway) and thus directs all connections (sticky) to the same server?

  • That is entirely possible however I'm not sure how to even check that. – nedwards86 Jul 21 '10 at 21:13
  • NLB settings ;) There are various modes how a session is handled there. – TomTom Jul 21 '10 at 21:21
  • I'm not seeing it so I'll list our cluster configuration: Cluster Parameters: Cluster operation mode: Unicast Port Rules: xxx.xxx.xxx.xxx on TCP 3389 in Multiple host mode with Single affinity mode. – nedwards86 Jul 21 '10 at 21:34
  • 1
    Reading documentation or using google you also do not like? Google, "nlb single affinity mode" points me to technet.microsoft.com/en-us/library/cc738968(WS.10).aspx which says ". When Single affinity is enabled, the clients port number isn’t used and the mapping algorithm uses the clients full IP address to determine load distribution. As a result, all requests from the same client always map to the same host within the cluster.". Guess what - all the requests from one gateway end up on one server. – TomTom Jul 22 '10 at 5:19
  • I strongly suggest reading the documentation for NLB. You area laready pointed to some good starting point by me. Behavior is as configured by you ;) – TomTom Jul 22 '10 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.