I am testing an application on clean Win7 Enterprise VMs but I am seeing different UAC behavior between VMs reached over RDC than with physical machines running the same O/S. The VMs are hosted on Virtual Server 2005 R2.

I am trying to determine if there are any compatibility issues with the application on Windows 7, specifically around UAC issues, but I am not getting the UAC elevation prompts over Remote Desktop when connected to the VM as I do on physical machines.

For example, if I mark the Command Prompt shortcut on the Start menu as 'Run as Administrator', I get a UAC prompt on my own physical Win7 Ent. workstation which is set to the default UAC level (3 out of 4); but on the VM, which is set to the same default UAC level, I do not get a prompt if I do the same thing to the CMD shortcut on that machine.

Does Windows suppress the UAC prompts over RDC, or do I have some other configuration difference that I'm not aware of?

Please let me know if there's some additional info that I should provide and I will update the question.

TIA, Matt


Windows can be configured to not show UAC prompts, but i believe thats a system wide config (ie youd see the same thing at the console as you would over RDP). They can definitely show up though, so it sounds like your servers have some configuration differences.

heres a technet article about the various keys: http://technet.microsoft.com/en-us/library/dd835564%28WS.10%29.aspx

| improve this answer | |

Are you certain that the UAC Group Policy settings are the same on all of the machines? Look in Local Policies > Security Options in secpol.msc, and scroll down to the User Accounts Control section. Generally, UAC behavior over remote desktop should be identical to UAC behavior logged into the console.

| improve this answer | |

I know this is avoiding the question, but you can use VMRCplus to open a connection to the VM where it thinks you're logged into the console.

| improve this answer | |
  • Well, that might show me if there's a clear difference with UAC prompts between the console and the remote sessions. I'll give it a try -- I do have VMRCPlus already installed. – Matt Jul 23 '10 at 19:36
  • Still no prompts using VMRCPlus, although the shortcut property tabs were a little different through the console for some reason. I even tried cranking the UAC setting to high and restarted the VM. – Matt Jul 23 '10 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.