I'm running ubuntu server lucid on a Dell Dimension 3000. I'm running headless and when I have a display plugged into the VGA, it's fine, so it must have something to do with the display drivers. When SSH'd in I run htop and at EXACTLY 10:01 uptime, it stops responding. Nothing interesting in /var/log/messages. It's upgraded from 9.10.

Has anyone had this issue or know how to fix it?


This sounds like it might be related to the linux console screen blanking, but this is just a guess. Like it's trying to blank the screen and triggering something that causes a lockup when doing it without an attached monitor. Or maybe when activating powersaving on that screen.

Try this and see if it makes a difference.

setterm -blank 0 -powersave off < /dev/tty0 > /dev/tty0

Update: Did you try the stuff that worked before with the previous version of Ubuntu on the same hardware? Ubuntu server 9.10 freezes up after ~10 minutes

  • Yeah, I did try it. I'm seeing that my update-grub command is probably not running correctly. – Matt Williamson Jul 25 '10 at 3:41

Ended up reinstalling from scratch. The server's been running for 14 minutes headless now. Not the best solution, but hey.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.