All, I've got a Windows XP client which is unable to query DNS for local or internet looks. Even using ping fails to work. However if I run nslookup from the command line it works fine. But nothing else does.

I've also noticed that when I run msinfo32 I get WMI errors. If I try an reinstall WMI using the below, it prompts me for the Windows XP SP3 disk. I've downloaded SP 3 and expanded it, but when I point it to that folder there are still files that it can't find.

rundll32.exe setupapi,InstallHinfSection WBEM 132 %windir%\inf\wbemoc.inf

I'm in the process of reinstalling SP3 on the machine now to see if that fixes it. The only errors that I see in the Application and System log are about how it can't locate the domain controllers.

TCP connectivity to the machine is working OK as I can remote desktop to the machine without issue (I'm assuming my credentials are cached). Windows Firewall is disabled as is the firewall within Trend Micro. I've tried disabling Trend Micro to see if that helps which it didn't.

If reinstalling SP3 doesn't help any all I can think of is to have the user format the machine and reinstall.

I'm open to all ideas here, crazy or not.

  • 1
    it seems that nslookup doesn't use system level calls for name resolution. here is an article that explains some of it cbfive.com/blog/post/PING-vs-NSLookup.aspx -- my assumption about your problem is that you have some mismatched, missing, or corrupt files on this system.
    – johnh
    Jul 26, 2010 at 21:00
  • @johnh that's my assumption as well, hence the SP3 reinstall.
    – mrdenny
    Jul 26, 2010 at 21:10
  • did sp3 work, I'd guess not.
    – tony roth
    Jul 27, 2010 at 3:41
  • have you done the following support.microsoft.com/kb/299357
    – tony roth
    Jul 27, 2010 at 3:43
  • Sorry, I forgot to update here as well. SP3 reinstall did do the trick. Appears to have fixed all the WMI errors that I was having on the machine.
    – mrdenny
    Jul 28, 2010 at 2:22

3 Answers 3


You might want to check to see if the "NetBIOS TCP/IP Helper service" has been disabled for some reason. When that gets turned off, name resolution behaves erratically on XP.


Check to see your Primary and Secondary DNS servers are responsible for the same zones.

I had this issue at home where I chose to have a Win2008R2 DNS server, and my Cheap home router as the secondary DNS.

Because the Win2008R2 Primary DNS server was authoritative for a few extra zones it caused a lot of grief.

To test, simply remove your secondary DNS server!

  • @Kortina, this should really be a question on its own, but, having multiple DNS servers listed is really a bad idea if they're completely independant. The system is designed for redundancy. if you need this, you should point your Windows DNS to use your router as a forwarder, or even better, just use Root Hints and ignore your router/ISP DNS alltogether. Jul 27, 2010 at 5:00
  • My workstations were exhibiting the same symptoms as listed in the question. NSLookup worked fine, but trying to ping machines on my local subnet failed. I now know that the Primary and Secondary DNS servers set should be responsible for the same zones. It might fix this problem, and is worth a look.
    – kortina
    Jul 27, 2010 at 6:21
  • This wasn't the problem here. All the internal DNS servers were working properly and only this one machine was having the problem.
    – mrdenny
    Jul 28, 2010 at 2:23

The solution in this case was a simple reinstall of Windows XP SP3 and everything was then able to resolve DNS correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .