I'm trying to get a scheduled task to run on Windows Server 2008. It has been working fine for months, and then hung, so I killed it, and now I can't get it to start. (In case it's not obvious, I'm not a Windows sysadmin by any stretch of the imagination. I inherited responsibility for this system, more or less.)

The error it gives is: "The user account does not have permission to run this task". The task's "author" is "A". The task's "When running the task, use the following user account:" is "B". And my user is "C". All of A, B, C are members of the Administrators group, so I'm a bit puzzled as to why it thinks I don't have permissions to run this.


5 Answers 5


I have found the cause of the error is in the C:/Windows/System32/Tasks folder. When the task is created, a XML file is created in the folder. The problem is the security permissions, under properties, on this file does not allow the user you created for the task to have execute permissions. The other issue is when you create the task in the GPO it doesn't allow you to configure for which operating system. The snap shot above is the task scheduler in Windows 7 which does not match the Server 2008 R2 GPO Task Scheduler.

  • 3
    This solved my issue with running scheduled tasks. I've had this issue for a long time, but settled with running the commands manually instead. Simply opening that folder in Explorer triggered a permission prompt that I just had to accept. I can manually run scheduled tasks just fine after this Jan 15, 2016 at 11:06

Try deleting and recreating the task. It sounds like the ACL on the task may have gotten corrupted.


I think you can go to C:\Windows\System32\Tasks folder. There find your job folder and finally your job file. Right click and select Properties -> Security -> Advanced (Button) -> Owner (Tab) -> Edit (Button) and change owner to the user you are logged in or to the administrator and press OK.

Again right click on the file and Properties -> Security -> Continue (Button) and check whether the user you are logged or administrator has full control over the file. If not, click on the user or administrator and click on the Full Control check box.


There is a box you can check when creating or editing the task that says Run with highest privilege. Make sure that is checked.

enter image description here


"The Task runs under domain credentials (which also happen to have local Administrators membership). When the Task is created, I get the same "the user account does not have permission to run this task" message.

If I export the Task to XML, delete the task, then import the XML file, the presumably identical Task thus created runs without problems."

MS Technet: the user account does not have permission to run this task

  • Doing this worked for me as well. Jun 21, 2022 at 10:44
  • 1
    Worked for me but also I exported it a second time and it was the same XML file, All of my tasks in my folder C:\Windows\System32\Tasks\Nanaimo have a modified date of 2 months ago, the same date I l updated to windows 2022 so I wonder if this is a cause
    – Jeff
    May 13 at 0:38

You must log in to answer this question.