I have installed an evaluation version of SQL Server 2008 r2. The installation went fine. However when I tried to start the service, I got an error message alert that the service could not be started and advised to check my event log. And this is what I could find in my event log:

FileMgr::StartLogFiles: Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file 'e:\sql10_main_t.obj.x86fre\sql\mkmastr\databases\objfre\i386\modellog.ldf'. Diagnose and correct the operating system error, and retry the operation.

E: is my CD Drive and I dont know how it could try to find a file in that location. Any help would be appreciated. I want to start on a few samples on sql server 2008 R2 but this is realy blocking me :(

migrated from stackoverflow.com Aug 2 '10 at 2:42

This question came from our site for professional and enthusiast programmers.

  • A quick search turns up quite a few instances of this problem having been reported. Which drive did you install SQL Server from? – Will A Jul 31 '10 at 23:23
  • I downloaded the setup file from microsoft site and ran from the following location C:\Users\SARAVAN\Downloads and sql server got installed in my C: Drive – SARAVAN Aug 1 '10 at 1:01

All SQL Server database files, including tempdb, must reside on uncompressed folders. The problem you mention usually occurs when the server cannot create tempdb at startup because the files are compressed. The file name you see (e:\sql10_main_t.x86fre...) has nothing to do with your deployment, it is the path used during build time when the master database that ends up on the CD/download media is created. This path is the changed during installation by the SQL Server setup. In your case, the change did not occur because the setup could not startup the database to make the change (this is part speculation on my part, since such problems are hard to investigate without proper setup/startup logs).

I'd recommend you uninstall this instance, then attempt a new installation making sure the database data folders you chose at install are not compressed (note that by default they inherit the parent folder compression settings).


Hope this helps you...

In order to resolve this you have to rebuild the database using this command string below.
This command MUST be run from this directory.

C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Release


If you are using Windows authentication you can ditch the strong password portion of the command like so.


You can read more on the issue at http://msdn.microsoft.com/en-us/library/dd207003.aspx. Hope this can help somebody out.


Take a look @ SQL Server wont start on my 64-bit virtualization slice on serverfault. Not exactly the same problem - but I expect it's a very similar solution that you require.

  • I referred to the URL you suggested. As instructed I tried to start SQL server in command line in single user mode but I got a error message hard stop alert with no message in it. – SARAVAN Aug 1 '10 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy