I am using VMware Workstation 7.0.0. I'm not able to set up the network connection between Host OS (Windows 7 Ultimate) and Guest OS (Windows XP Service Pack 2) to connect Host OS with the internet when my Guest OS is connected directly. When Host OS is connected with the internet directly, then Guest OS is automatically connected with the internet because of the default network settings configured by the VMware Tools. But I'm not able to connect Host OS with the internet when my Guest OS is connected directly. What can I do? Please help me.

[I am using NAT connection]


If the guest O.S. connects directly to the Internet (how, BTW?) then you will need it to perform NAT for the host system. Windows XP can do that with its Internet Connection Sharing feature.

  • Connect your XP guest system to the "Host only" VMware network.
  • Disable the VMware DHCP service on that network if it's enabled; XP will do that when ICS is enabled.
  • Configure the host's "host only" virtual network adapter to use DHCP.
  • Configure the guest's network adapter to use as its IP address (it will do that anyway).
  • Connect the guest to the Internet; if this requires a second virtual network adapter connected to a physical network, use a bridged one.
  • Enable Internet Connection Sharing on the guest's Internet connection and configure it to share the connection to the "Host only" network.

This is how it should basically work. But if you only have one physical network adapter on the host system, and you are using that for Internet connection, connecting only the guest system and sharing the connection will be somewhat more tricky.

Why would you want to do that, anyway?


I always setup my VM's to be bridged, this way they are connected just like a regular system. Both your host and guest will have internet access.

  • That is, if you have a private network or some free public IP addresses. If your host system gets a single public IP address from your ISP, things are a bit trickier. – Massimo Aug 4 '10 at 17:45
  • Oh, true. Sorry :P Follow Massimo's suggestions, that would get everything working. – Jason Taylor Aug 5 '10 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.