There is a simple way to check the integrity of a backup made with Windows Backup in Windows 2008 Server Enterprise (not R2)? Today i tried to restore some files from a backup I made some days ago, and the Windows Backup snap-in reported that the file was unreadable. I think the corruption occurred due to the network share in wich the files were being stored went offline during the backup process, that was my fault.



  • Note that it is always a good idea to run a test restore of your backups on a routine basis (i.e. every n months) to validate that your backup will be genuinely useful in the event of an actual emergency. – Skyhawk Aug 2 '10 at 20:47
  • Sure. Luckly this wasn't an emergency. Thanks for the advice. – Norba Aug 3 '10 at 5:19

wbadmin get versions -backuptarget:\\server\share

if you need more details:

wbadmin get items -version:mm/dd/yyyy-hh:mm -backuptarget:\\server\share

  • Unfortunatelly I overwrote the corrupted backup and I won't be able to make a test. I will accept this as an answer. Thanks Chris. – Norba Aug 3 '10 at 5:14
  • So, my backup became corrupted again. This time I really don't know why. The problem is that these commands don't report any error. None of the two. I'll keep looking. – Norba Aug 17 '10 at 12:02
  • @Norberto, What kind of server are you backing up to (the one hosting the file share)? Is it a NAS, Samba Server, or older Windows box? – Chris S Aug 17 '10 at 12:28
  • It's a Windows XP SP3. – Norba Aug 17 '10 at 12:34
  • You've got me; I don't see anything inherently wrong with what you're doing. It's a support configuration. Perhaps the disk has issues? Have you tried running chkdsk on the XP box, or checking the event log for SMART messages? – Chris S Aug 17 '10 at 17:50

I do not think the above commands are 100% useful. I tested them on injured backup (i know it for sure) and both commands have confirmed the correctness of this backup.

use the commands: wbadmin get versions -backupTarget:x: -machine:Xxx wbadmin get items -version:xx/xx/xxxx-xx:xx -backupTarget:x: -machine:Xxx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.