I am troubleshoot/configure "talk" http://linux.about.com/od/commands/l/blcmdl1_talk.htm Will be using it to securily communicate with other users, share logins and such and chat specially that we don't have our personal laptops with us all the time, it is neater to have a "server chat"

there is the talk client package and talkd daemon

they were previously installed

when i try talk mir@myhost.com - get get the following :

[No connection yet]
───────[ Error on read from talk daemon: Connection refused. Press any key...]─────────────────────
[Checking for invitation on caller's machine]

i try pgrep talk and pgrep talkd , it gives nothing

I try to start talkd using /usr/sbin/in.talkd it gives me : must be run from inetd.

I vi /etc/inetd.conf - the 2 lines

#:BSD: Shell, login, exec and talk are BSD protocols.
talk            dgram   udp    wait  nobody.tty       /usr/sbin/in.talkd      in.talkd
ntalk           dgram   udp    wait    nobody.tty     /usr/sbin/in.ntalkd     in.ntalkd

i change nobody.tty to root and udp to udp4 so it becomes

#:BSD: Shell, login, exec and talk are BSD protocols.
talk            dgram   udp4    wait root       /usr/sbin/in.talkd      in.talkd
ntalk           dgram   udp4    wait    root    /usr/sbin/in.ntalkd     in.ntalkd

i make sure /usr/sbin/in.talkd and /usr/sbin/in.ntalkd exist actually - i restart inetd - yet no sign of talkd on inetd

in my bug hunt , i reached this page : https://bugs.launchpad.net/ubuntu/+sour … bug/250971

Binary package hint: talkd Two problems:

  1. The talkd package puts its inetd info into /etc/inetd.conf instead of /etc/inetd.conf.d
  2. The info itself is incorrectly formatted for the inetd that talkd depends on: talkd is using a 'user.group' format and inet expects user only. I also vaguely remember a permissions problem but I can't be sure of it.

i tried to vi to /etc/inetd.conf.d - it gives new file - aka nothing already exists, should i create new file ? what are the format ? i already changed the nobody.tty group to root the followups on the bug reports sound chinese to me - any idea what should be done ?

help , help , help !

thanks a lot in advance

  • 1
    BTW, have you considered just setting up your own jabber server? It is 2010, and not 1980 you know...
    – Zoredache
    Aug 4, 2010 at 0:24
  • 1
    It's rare to have everyone logged into the same box. talk should work in your case but I have to ask.. If you don't have your personal laptops what are you working on? dumb terminals? Aug 4, 2010 at 0:29
  • 2
    zoredache: all we need to share is login info, datapaths, info - a 5 mins info for team members that keep changing - it is not the 1980 - but this is dirty fast n easy imho :) I will try setup my own jabber server when i have some free time :P --------------------------- Alexandre: well many times,files are on server,u just ssl - or sometimes u are for example at the beach, they call u on emergency, u just login to collaborate with someone from ur phone shell :P without need for encryption n software to share passwords n critical data Aug 4, 2010 at 1:23
  • 1
    Use write on a local server or a more modern encrypted solution. Check out silc. There are security implications with talkd and it's pretty much obsolete at this point.
    – Warner
    Aug 4, 2010 at 4:40
  • Have you cosidered just leaving a text editor in screen open? If people need to talk connect to the ame session and start writting.
    – Zoredache
    Aug 4, 2010 at 7:30

2 Answers 2


You understand that services offered by inetd are launched on-demand right? Nothing served by inetd will actually start until some client actually attempts to connect to that port.

I just installed on my Debian 5.0 testing box.

  • I did a apt-get install talk talkd
  • I restarted the inetd /etc/init.d/openbsd-inetd restart
  • I allowed udp/517 and udp/518 with iptables

Then I was able to connect with talk username2@localhost. I saw the message as the other other test user and did a talk username1@localhost and the connection was established.

  • i will check the iptables - 3rd point you mentioned - Honestly, someone else installed talk/talkd, it didn't work, so they told me to check- i tried to fix/re-install using apt-get, it was not available, i need to update the list or maybe manually re-install - but how wrong can installing talk-talkd go wrong ? Thanks for the tip :) Aug 4, 2010 at 1:27
  • This answer worked for me trying to talk locally on Ubuntu 12.04 LTS. Jul 31, 2012 at 13:49

Your use case really confuses me. in.ntalkd comes from another era, where eavesdropping was less common, it's all but obsolete now. You will be transmitting confidential information over an unsecured channel.

Having said that, bear in mind that inetd services are usually protected by a system layer called TCP Wrappers. in.ntalkd is usually binary linked to libwrap.

man hosts_access should help you solve your problem.

Like others, I really don't recommend your approach.

  • That's a bit of a harsh comment... :-) I was looking at a way to setup talk and this question helped me a lot. In my case, there is no confidential information being sent and both people are users on the same server. Granted, its use is now a very isolated case, but with sufficient warnings attached, some people might actually still want to use it...
    – Ray
    Jul 30, 2020 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.