I'm trying to make a bootable OpenBSD CD image on Mac OS X Snow Leopard (10.6). Unfortunately, the expected route to success, download + burn with Mac OS X, does not result what seems to be a bootable CD.

I suspect the problem lies with the burning process with Mac OS X. I am downloading the images (install47.iso, cd47.iso and cdemu47.iso), and trying to burn them with Disk Utility, which I presume is the same as the Finder "Burn" command when you right-click on an ISO image. I've tried both methods of burning the ISO.

I've also tried creating .DMG files from the .ISO files in a few ways (e.g. copying the files, creating a read-only image from the contents of the ISO, etc.), and then burning those. As none of those attempts have proven successful, I won't repeat the details here.

That being said, I'm not certain the problem is with the burning process. The target machine is the only machine that I can test the boot-ability of the burnt CD is a Compaq Presario 5320CA (circa 2001). The BIOS from this machine certainly indicates that it can boot from CD, but it consistently displays the messages "Non-system disk or disk error.". I've tried burning several CD's, however, which I'd expect to eliminate error.

The target machine seems to be able to read the image fine once it boots into the currently installed operating system (i.e. Windows XP). The disc certainly seems readable.

I'd be very much obliged for any suggestions on how to burn a bootable OpenBSD 4.7 image from Mac OS X -- or feedback and suggestions on what may be the problem.

Incidentally, I don't have Roxio Toast, and I would prefer solutions that do not involve buying it or other commercial packages. I'm investigating using cdrecord now, and if that proves successful I'll post results here.

Thank you.


  • You seem to be doing everything correctly. This may sound silly, but are you using the x86 versions of the OpenBSD .iso's. There are also macppc ones that won't do much of anything if you try to boot them on a PC. – gabe. Aug 9 '10 at 17:44
  • When you put the CD in to a drive after burning it, what shows up when you open the drive? A big file called <name>.iso? Or a series of files? If it's a series of files, it sounds like you might be burning a usable disk, but the computer isn't able to boot from it (maybe what Gabe mentioned) – Bart Silverstrim Aug 9 '10 at 17:46
  • @gabe: Yep, using the i386 .isos, but good question! @Bart Silverstrim: The files showing up are those in the ISO that one would expect (i.e. TRANS.TBL, 4.7, 4.7/i386, etc). Everything in the ISO is being written to the disc. Incidentally, however, the 'information' tab says "Bootable: No". I wonder if/how the El Torito extensions are handled by Mac OS X is an issue. – Brian M. Hunt Aug 9 '10 at 18:31
  • This sounds awfully familiar... I seem to recall having a similar issue once upon a time, trying to do the exact same thing, unfortunately, I can't remember what I did to make it work. – gabe. Aug 9 '10 at 19:41
  • @gabe Aye. If I didn't need to install OpenBSD for every 6 years or so I'd be way more up to speed. ;) I may install Ubuntu (which has a liveCD that boots fine) and install OpenBSD from bsd.rd:--ramdisk. – Brian M. Hunt Aug 10 '10 at 1:43

You could also try using 'dd'... should work, though I'm not super familiar with using it on the mac.

| improve this answer | |

What happens when you try: Launch DiskUtility, Images menu, select your .iso, click Burn

That's how I've burned my BSD .iso's in the past

| improve this answer | |
  • Aye, that's what I tried. Works fine with e.g. Ubuntu 10.04 Live CD; OpenBSD 4.7 CD doesn't boot. – Brian M. Hunt Aug 12 '10 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.