Got a problem with NIC failover with iSCSI.


  • A server with 3 NICs. One NIC is local network, other 2 are SAN. Using Microsoft iSCSI Initiator.
  • A managed network switch.
  • A QNAP SAN, connected via iSCSI to server. Dual NIC, failover mode.

All works fine until (for testing purposes) you disconnect one of the server's SAN NIC's cables (well, actually just disable port on a switch). Then everything breaks, copying files stops, server most of the time loses all iSCSI mapped disks, etc. If disconnecting one of the cables on QNAP, all works just fine, without any noticeable delays.

So far, I've tried multiple Multipath Session / MCS connection configurations:

  • Single session, multiple MCS (one connection, two connections, round-robin or failover for two connections)
  • Two sessions, multiple MCS (one connection, two connections, round-robin or failover for two connections).

Doesn't matter which NIC is active, as soon as you try to do the failover it dies completely.

As much as I researched online everything shows that the failover should work that way, but it doesn't.

Any ideas? What am I doing wrong?

1 Answer 1


Most QNAP SANs do not support failover (they don't implement iSCSI3-PR; there's a reason they're cheap). What model do you have?

The really short version of connecting to an iSCSI target in Server 2008 (or R2) with MPIO.

  1. Enable the MPIO feature.
  2. Run mpiocpl, on the Discover Multi-Paths tab; check Add support for iSCSI devices; you might have to reboot your computer. If this whole tab is grayed out, it's already enabled.
  3. Run iscsicpl, on the Discovery tab add a Discovery Portal; pop an IP of the Target in.
  4. Go to the Targets tab; select the appropriate target, click connect. Check both boxes and click OK.
  5. Select the Connection, click Devices, click the MPIO button. It should show one active session. Close the details window and the device window.
  6. Select the Connection, click Properties. One session should currently appear. Check the box next to the session and click MCS. Note the IPs used. Close the MCS window. Click Add session, check both boxes, click Advanced. Select the IPs from the drop downs that are not already being used. Click OK twice. If your target only has one IP, it gets re-used; this will depend on how your iSCSI Target works.

You should now be able to see two session; if you check the box next to one of them, then MCS it should show the IPs (each one having different IPs).

Note this setup is for MS's iSCSI Software Initiator only; if you use other software, or a NIC with iSOE the process is different (usually). Depending on how your iSCSI Target works you might have the same destination target for both sessions. If your target has many connections (common on high end units) you may or may not have to establish a session for each; consult the documentation that came with your target.

  • 1
    Thanks for the quick reply. The model I have is "QNAP TS-439U-RP/SP Turbo NAS". The failover on SAN itself works fine, but not from the server. I've tried 2 different servers, they both act the same (granted, servers are identical).
    – Dami
    Aug 10, 2010 at 8:14
  • That model should work as long as your on Firmware v3.2.0 or newer; though I'd recommend the v3.3.1. Do the NICs support iSOE and are you using it if they do?
    – Chris S
    Aug 10, 2010 at 13:13
  • I'm on V3.3.1. I went through NIC settings, unfortunately it doesn't support. All there is as far as Offload: IPSec Offload IPv4 Checksum Offload Large Send Offload (IPv4) Large Send Offload (IPv6) TCP Checksum Offload (IPv4) TCP Checksum Offload (IPv6) UDP Checksum Offload (IPv4) UDP Checksum Offload (IPv6)
    – Dami
    Aug 10, 2010 at 14:45
  • That should be fine if it only does TOE (Chimney); it just changes where you setup MPIO (if the cards support iSOE, it's configured on the card; not in the iSCSI control panel). See my edit for an overview of the install process, just to be sure we've got everything straight.
    – Chris S
    Aug 10, 2010 at 16:33
  • 1
    hey Chris, I reconfigured iSCSI per your recommendations. Turns out that I didn't have MPIO enabled. Well guess what, it freakin' works now. As a clockwork. Thank you so much for helping me out. I really owe you one. If you're going to visit Barcelona, Spain, email me (email is my first name at my website), I'll buy you a beer :)
    – Dami
    Aug 11, 2010 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.