If I run an SSH server on my Windows 2008 server box on the default port 22 I always get Operation Timed Out on the client. If I run it on another port (say 2222) it works fine.

I've opened up the firewall. Netstat shows that the server is listening on the correct port.

I have used two different Windows SSH servers (freeSSHd and WinSSHD) and they both have the same result.

What else could be causing the difference between running the SSH server on port 22 versus port 2222?

  • 2
    can you provide more information? Are you connecting from the local machine, a remote client, a client on the same LAN. If you haven't tried connecting from the local host, give that a try. Also you might want to attempt a "telnet localhost 22" to see if it's the ssh server that is responding. Barring that, check the log files to see what's going on. – gabe. Aug 9 '10 at 20:27
  • Thanks for the suggestions. I tried connecting from the local machine and that worked. I am connecting from the same LAN. The machine is a VM and I can SSH into the physical machine. – mikelberger Aug 10 '10 at 13:17

Is the ssh server on port 22 being hammered by brute force attacks? Putting it on a higher port number reduces these, potentially allowing it to respond more quickly to your requests.


I'm not sure why but this was eventually resolved by a reboot. My only thought is that the firewall changes I made hadn't taken affect and when I rebooted this morning it worked.

Thanks Peter and Gabe for the debugging tips.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.