The error message is:

 error processing /var/cache/apt/archives/debianutils_2.30_i386.deb (--unpack):
 trying to overwrite `/usr/sbin/add-shell', which is also in package passwd

How can I solve this problem? I'm doing

aptitude safe-upgrade

ouptput of dpkg -S add-shell:

passwd: /usr/sbin/add-shell
  • Did you try aptitude install passwd and then aptitude safe-upgrade? – lg. Aug 10 '10 at 10:01
  • Strange thing is that the mentioned add-shell file is in debianutils in both Etch and Lenny. Could you tell us what the output is of dpkg -S add-shell? – Jasper Aug 10 '10 at 10:09
  • @lg: gives me the same error when trying aptitude install passwd :-/ – yas4891 Aug 10 '10 at 10:10
  • @Jasper: Output has been added to the original post – yas4891 Aug 10 '10 at 10:11

Short answer: first upgrade from unstable etch to stable etch, then from etch to lenny.

It looks like you didn't have an up-to-date etch installation, according to the discussion for bug #458452. Upgrades are supported from one stable release to the next, and between successive states of an unstable release (including its final stable state), but not always for more complex cases. To upgrade to a stable etch even though it's disappeared from Debian mirrors, get it from archive.debian.org.

If aptitude is refusing to do anything until you repair the problem manually, you can run dpkg --force-overwrite -i /var/cache/apt/archives/debianutils_2.30_i386.deb. However going via etch would be a better idea (and you wouldn't have this problem, because the debianutils package from etch declares dependencues that cause passwd to be upgraded first).

Note that when upgrading to a new release, you typically need full-upgrade rather than safe-upgrade.

  • Mispelling? full-upgrade -> dist-upgrade – lg. Aug 10 '10 at 10:28
  • I had upgraded to archive.debian.org/ etch main before calling aptitude safe-upgrade. I've been following the official upgrade guide (that's why I put the safe-upgrade first, the dist-upgrade will follow later on) – yas4891 Aug 10 '10 at 11:01
  • @yas4891: what version of passwd and debianutils do you currently have? This error shouldn't have happened if you already had a stable etch system. – Gilles Aug 10 '10 at 11:27
  • @lg: full-upgrade and safe-upgrade are synonyms of dist-upgrade and upgrade respectively. – Gilles Aug 10 '10 at 11:28
  • @Gilles: Currently running through an aptitude upgrade with the legacy (etch) servers. He's doing quite a lot at the moment. So maybe I was wrong and didn't correctly upgrade my system. Sorry for that false information. I'll keep you posted whether it worked – yas4891 Aug 10 '10 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.