I installed 4 new Windows 2008 R2 Servers. All are joined to the domain. One out of the four will not browse to our DC without using a FQDN. I can ping the DC server and see it in Network neighborhood but when I click on it I get Windows cannot access \SERVER. BUT accessing it by using \server.domain works fine. It is only having problems with the one DC server. Able to browse every other server with UNC without using FQDN.This is the only machine on our domain that is experiencing the problem and have tried different user accounts.

  • Are the DNS settings on the one that can't browse identical to the ones that can? – DanBig Aug 11 '10 at 15:22
  • what do you get when you ping shortname vs nslookup shortname? – tony roth Aug 11 '10 at 16:59
  • I'm having the exact same problem. Pinging the shortname gives a response, but SMB connections to the shortname fail. Both work using the FQDN. No idea what's going on. – Nic Jan 12 '11 at 18:31

I had this happen with me. The server it was connecting to did not have NETBIOS enabled, so the fallback to NETBIOS over TCP/IP did not work. I enabled NETBIOS on the remote machine (the server hosting the windows share) and restarted the workstation service on the local machine, it started working again after that. It may be worth just restarting the workstation service and seeing if that does it for you, if not check to see if NETBIOS is enabled.


If you check that the DNS and Netbios are working well, another option that happend to me sometime was a wrong entry in the Credential Manager.

If there is a bad credential save you will can access using the FQDNS but not if you write only the name, not matter if your dns suffix is ok.

Try deleting all entries of your credential manager, this very probably will fix your issue.


Sounds like you might not have a default domain configured in the TCP settings on that machine.


This seems like a DNS error. Check again how the server is declared in your DNS server settings. By that I mean the settings about the machine in your DNS zone, not the DNS server settings in the machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy