I am having an issue with a machine on my company network where it has joined the domain OK and the machine itself can happily connect with play with other machines on the network but nothing can connect to it (or indeed ping it).

What I would like to achieve to to be able to remote desktop onto it (obviously I have turned this option on in the settings)

The machine is running Windows XP, the firewall is off and it is getting an IP on our network. I am a bit of a networking n00b so I don't know what other information is relevant.

Any ideas on what could be causing this?


As far as connecting to this PC via Remote Desktop goes, please verify two things and then run a test for me.


  1. The Windows Service "Terminal Services" (Control Panel, Administrative Tools, Services) is started (if not, right mouse click on it and select Start, if you cannot start, verify under its properties that it is not disabled).
  2. The Computer's System Properties "Allow user to connect remotely" (a check box) is enabled. Located under Control Panel>System> Remote tab). << It looks like you already checked this, but just to be safe I wanted to mention again. >>

After verifying those two things, test that the Terminal Server is running and bound to a TCP port on your computer. To do this, type the following at a command prompt:

netstat -anp tcp | find /N "3389"

That should return something like this:

  TCP                   LISTENING

If it doesn't, Terminal Service isn't running, or is running on a different port. You could always run something like this to see if its bound to a different port:

netstat -anpb tcp

The result would look like this:

 TCP<some number>                LISTENING       1900

  -- unknown component(s) --




Microsoft Support Article 299357 (I'm only allowed to post one URL) describes how the listening port for RDP may have been changed from 3389 to some number.

As far as not being able to ping this computer goes...can you upload the IPCONFIG for both machines? Are there any hardware firewalls between them?

Like another member mentioned, it's possible this computer has another software firewall blocking inbound traffic, aside from the Windows Firewall. I'd check in the Security Center (which should detail if any are active).

Also, you might want to see if any TCP/IP filtering settings have been enabled for this NIC.

If nothing else, you could try resetting the TCP/IP settings...Microsoft Support Article 299357.

Good luck!

|improve this answer|||||

Does your edition of XP support Remote Desktop?

Can the machines see each other on the network? (Ping them) > ping ipadress(X.X.X.X)

|improve this answer|||||
  • It does, or at least the option is there for Remote desktop. It can, it can ping and communicate with anything I have tried (including the machine I am trying to remote in with) – Toby Aug 6 '10 at 10:56
  • Is the other machine Windows,Mac,Linux or Unix? I assume you ve got /defined user&pass on remote desktop connection. – Anonymous Aug 6 '10 at 14:01
  • It is Mac, but we have tried from various machines and we have tried defining credentials and setting it to prompt for them. Nothing is working. – Toby Aug 6 '10 at 14:14
  • Okay,so In Systems Properties -> Remote tab: you gotta mark the second one "Allow connections from computers running any version of Remote Desktop(less secure) " – Anonymous Aug 6 '10 at 16:08
  • That has already been ticked. I think there is a bigger problem than remote desktop (since ping isn't working either) – Toby Aug 12 '10 at 15:54

I have had this happen on numerous occasions. Sometimes whilst joining a Windows Domain, something goes awry. What I have done in the past is to delete the computer name from Active Directory, then disjoin the Domain (from the computer: right-click my computer, select properties, select the computer name tab, click change. click the workgroup radio button and type in a workgroup name. Finally restart the computer). After the computer restarts, you can then log in and rejoin the domain (same process as above, only select the domain radio button and type in the name of your domain). This should solve your problem.

|improve this answer|||||
  • +1 Have seen same but no idea why it happens. Easy to test. Alos check for ant third-party firewall apps. – Dave M Aug 6 '10 at 12:31
  • Unfortunately that didn't seem to do anything - it joined the domain fine but I still cannot ping or connect to it. – Toby Aug 6 '10 at 13:17
  • @DaveM - I can't see any third party firewall/network tools on it that could cause these issues. – Toby Aug 6 '10 at 13:26

Check the properties of your NIC in Control Panel, Network Connections. You need to have both Client for MS Networks and File and Print Sharing enabled.

|improve this answer|||||

If I understand you correctly, you have a WinXP machine that you cannot ping, connect to with RDP, or otherwise route traffic to. This wouldn't be anything specific to RDP, it would be a more general networking issue.

Try setting the XP machine to a static IP and see if you can communicate with it then. If you can't ping it, which failure message do you get?

|improve this answer|||||

When you ping and remote be sure to try using the IP address instead of the name in case DNS is not working correctly.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.