0

I need to migrate two Windows virtual machines running as a Xen DomU to VMWare ESXi.

I've migrated a lot of the Linux and Solaris DomU without any problems, but don't know what to do with Windows. After I convert the disks, it simply doesn't boot. It gets stuck on "Loading acpitabl.dat" and then freezes. I've tried to uninstall XenServer Tools before the migration but this doesn't help.

I believe the problem is in the change of the disk controller from QEMU IDE emulated by Xen to LSI SCSI emulated by VMWare. Any suggestions how to solve this?

Windows I'm currently fighting with: Server 2003 64Bit

  • finally migrated with acronis universal restore – disserman Aug 13 '10 at 15:15
  • you mentioned that you've been able to migrate linux DomU without any problems. Man I've spent a lot of time on that and am spinning my wheels. Can you point me in a good direction?? - ps I know this is an old post, hoping you'll notice my comment... – Patrick R Mar 7 '11 at 20:12
1

You could try running vmware converter on the actual VM's whilst on the xen environment and then pointing the converter at your ESXi box as the target.

This should convert your virtual machines automatically and put them straight on to the ESXi environment without havign to worry about manually converting disks.

  • VMWare Converter fails at 95% with an error "Windows can not write to \Device\vstor2-mntapi1-XXXXXXXXXXXXXXXX\$reconfig". Converted machine boots but fails with BSOD 7B. I've run converter standalone directly on the DomU.. – disserman Aug 13 '10 at 9:30
0

Try the fix for the STOP 7B problem; it fixes a lot of P2V and V2V "Windows doesn't boot" problems.

  • it seems to be for 32 bit environment only, isnt' it? – disserman Aug 12 '10 at 20:08
  • @disserman: Yes, sorry I didn't see they were 64bit. It's probably the same problem, but the solution would be different. – Chris S Aug 12 '10 at 20:16
0

Steps that worked for me:

1-Make sure XenServer Tools are uninstalled from the windows host.

2-Delete "xen.sys" from drivers folder (Windows/system32/drivers).

3-Export the VM or run VMware Converter.



Note:

If you can't access original image then boot into safe mode, uninstall xen tools (https://4sysops.com/archives/tip-how-to-install-and-uninstall-a-program-in-safe-mode/) and delete xen.sys, then boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.