2

I'm using TightVNC to connect from my work computer (Fedora) to my home desktop (Windows 7).

For some reason when I attempt to type in the remote desktop (vnc viewer) the keystrokes aren't sending to my home desktop.

Anyone have any ideas as to why this is and/or how to fix it?

2

It is possible to have VNC in "read-only" mode. Have you checked that? When "read-only", no input events (keyboard or mouse) are transmitted to the remote end.

  • didn't work for me: my MOUSE control IS getting to the server; KEYSTOKES are not. Client: RealVNC client 6.0 on Windows; server: tightvncserver on Ubuntu 14.04. I've checked my client config; the settings are similar to connections where keystrokes are correctly sent... – Dan H Dec 12 '16 at 14:19
2

If you typed in the password twice on the TightVNC server, then you didn't confirm the password, you set the read-only password to be the same as the access password. Guess which one takes precedence when logging in (I've done this to myself a few times...)?

  • I checked this; wan't my issue. (My mouse control IS getting through, just not my keystrokes.) What could cause that? – Dan H Dec 12 '16 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.