I have a virtualbox image that I created using libvirt from Ubuntu 10.04. It assigns a fixed IP address. I can start it up on my Windows 7 VirtualBox, but I cannot get networking to work. My colleague loaded the same image onto his Windows 7 and networking worked as a bridged connection. Therefore, I know that the image is good, it must be something about my Windows 7 installation.

Any thoughts on where to look to get networking running in my virtual machine?

Thanks, Herb


Problem solved. Like most things, this was "operator error." It appears that I changed the MAC address of the virtual machine, thinking that it did not matter. I was wrong. The answer is here:

http://www.linux-solved.com/post/solved-udev-renamed-network-interface-eth0-to-eth1-1601.html .

I erased (mv) the file 70-persistent-net.rules and restarted the VM. Now networking works (bridged). The key was to look at dmesg.

Thanks so much for your help.


  • OK, so it did come down the to MAC/eth0 configuration within the VM. – user48838 Aug 15 '10 at 17:58

Do you have any other VMs working on that Windows 7 host? If so, what NIC types are those VMs set to? You might check to ensure the Virtualbox NIC drivers are installed onto the host.

  • No, I don't have any other VMs set on that machine. But this one runs on my colleague's machine. Can you tell me more about Virtualbox NIC drivers? Maybe that's what I am missing. I did use the device manager to update the driver for VirtualBox Host-Only Ethernet Adapter. That did not help so far as I can see. Do I have to reboot Windows or are you talking about something else entirely? Thanks for your help. – Herbert Roitblat Aug 15 '10 at 0:20
  • That should be fine. How was the VM moved over to the other instance of the VB host? Just the .vdi file or was its .xml configuration also moved as well? Have you verified the NIC type for the VM? What is the ifconfig output of the problematic VM? – user48838 Aug 15 '10 at 0:48
  • ifconfig shows only the lo interface, not eth0. I have a VMX file and a VMDK file. From the log: VirtualBox 3.2.8 r64453 win.amd64 (Aug 5 2010 14:00:56) release log 00:00:03.998 [/Devices/pcnet/0/LUN#0/] (level 4) 00:00:03.998 Driver <string> = "IntNet" (cb=7) 00:00:03.998 [/Devices/pcnet/0/LUN#0/Config/] (level 5) 00:00:03.998 Network <string> = "HostInterfaceNetworking-Intel(R) 82577LM Gigabit Network Connection" (cb=68) 00:00:03.998 Trunk <string> = "\DEVICE\{D03234BA-CE07-4401-8424-A2A2E1736662}" (cb=47) 00:00:03.998 TrunkType <integer> = 0x0000000000000003 (3) – Herbert Roitblat Aug 15 '10 at 5:46
  • You might try redefining the VM locally on the Windows 7 host and just attaching the VMDK (which is actually a VMWare virtual disk). If locally redefining the VM does not do the trick, then you might consider associating/defining the virtual MAC to eth0 within the VM. – user48838 Aug 15 '10 at 6:05
  • I can get another VM to work on this box building it on windows. My colleague can get this one to work on his machine. Original VM reports no eth0, no such device. dmesg reports: renamed network interface eth0 to eth2. sudo ifconfig eth2 up makes no difference. Is there a conflict or something? What could conflict? Thanks, Herb – Herbert Roitblat Aug 15 '10 at 15:52

I've found virtual box is a pain to get networking to work properly sometimes. I ended up just setting up a vpn on both machines like NeoRouter. I know this really isnt an answer to getting networking to work properly but its an alternative that I found easier.

  • I think that I don't understand. How can I set up a VPN if I don't have any connectivity? – Herbert Roitblat Aug 15 '10 at 0:21
  • I meant for sharing folders. I never had a problem with internet connectivity but for some reason VirtualBox likes to put the VM on a different subnet by default. Or it just did that for me.. – WalterJ89 Aug 15 '10 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy