I have a need to use Windows XP Mode in Windows 7 to run a legacy application, so I downloaded, installed and configured it on my machine as a test without any issues. The problem I am now having is I have done the same setup on the machine which needs to run the legacy software and WSUS seems to be getting confused as to which VM is which.

Here's what I have done so far on both machines (which seems pretty reasonable to me), can anybody see any flaws in my process?

  • Download and install the .msu file to enable Windows XP Mode
  • Download and install Windows XP Mode
  • Download and install the .msu file to enable Windows XP Mode without hardware assisted virtualization
  • Set the network mode to use the physical NIC (instead of the default NAT)
  • Renamed the VM to HOSTPC-XPMODE
  • Joined the VM to the domain and moved it in Active Directory to the appropriate OU

For the sake of argument, we'll call the 2 Windows 7 machines PC001 and PC002 (with PC001-XPMODE and PC002-XPMODE as the names of the VMs).

When I go into WSUS, it will show me status information for either PC001-XPMODE or PC002-XPMODE, but only one or the other - never both at the same time. It's almost as if WSUS is getting confused because it is an identical machine.

Am I missing something fundamental, or am I using it not actually as intended? This blog entry from the Virtual PC team talks about joining the VM to the domain, so I don't think I'm using Windows XP Mode incorrectly (but feel free to correct me if necessary).

  • Did you just configure one XP Mode VM and copy it to the second Win7 pc? – ErnieTheGeek Feb 3 '11 at 18:27
  • No, the XP Mode VMs were both installed separately, but they were installed from the same download (if it makes any difference). – Ben Pilbrow Feb 3 '11 at 18:30
  • I should also add that I STILL haven't tried the suggestion by James Sprinkle (yeah yeah shame on me I know). It's not particularly causing me any real issues, it's just weird. We've also managed to get upgrades to the software in question in the mean time, so XP mode isn't used any more. I will definitely try out the below suggestion though to see if it works. – Ben Pilbrow Feb 3 '11 at 18:33

I wonder if if Microsoft's XPMode image has a SUSclientID value leftover in the registry? That could explain WSUS thinking multiple XPMode machines are the same machine.

Check HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate before you join the XPMode machine to the domain, see if there is a SUSclientID.

I ran into this issue with WSUS when working with sysprep. If this is the same issue, see http://www.winserverkb.com/Uwe/Forum.aspx/wsus/1163/VBS-Script-to-fix-imaged-computers for a script to fix.


This is a classic symptom of duplicated SusClientIDs caused by cloning an image with an already present SusClientID.

Delete the SusClientID registry value from the registry key



and reboot (or restart the Automatic Updates service)

and THEN run wuauclt /resetauthorization /detectnow

which will force the WUA to generate a new (unique) SusClientID and reregister with the WSUS Server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.