I'm having an issue setting up exchange 2010. When I run the setup I get the following error:

[08/17/2010 01:28:42.0645] [2] [ERROR] Property CustomerFeedbackEnabled can't be set on this object because it requires the object to have version 0.1 (8.0.535.0) or later. The object's current version is 0.0 (6.5.6500.0).

I ran Setup.com /PrepareAD, Setup.com /PrepareSchema, and Setup.com /PrepareDomain which complete successfully.

As well as disabled IPV6 through in the registry as a couple websites said it could be related. The machine in question is in Hyper-V on a clean install of Server 2008 R2 with domain functionality at 2008 R2 as well.

Any help would be appreciated. Also I am doing a typical install.


It could be related to this:


Install the latest integration services and disable time sync on the VM. Then run w32tm /resync on the Exchange server. Make sure your times are synced up between DC and Exchange. Try the install again and let us know how it goes.

| improve this answer | |
  • Perfect, that solved it for me, I'm not going to have it in Hyper-V when it goes production I don't think I'm still planning that, I just needed a way to test it and make sure everything will work. – wolfvilleian Aug 17 '10 at 10:56

It is possible that the same machine (or machine name) was running a previous version of Exchange at some point? The current version of 6.5 make me believe that Exchange 2003 was around at some point.

If that was the case, check out this article toward the bottom where it talk about removing the Exchange 2003 settings from AD: http://support.microsoft.com/kb/833396

| improve this answer | |
  • Never had 2008 on it before, everything was fresh – wolfvilleian Aug 17 '10 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.