I'm trying to install Ubuntu GNU/Linux server (10.04 LTS, 64-bit) on a Dell PowerEdge 2900 server hardware, and when it comes to the disk and partition detection phase it says:

No disk drive was detected. If you know the name of the driver ...

I switched to another tty and tried to see the output of lspci and in the output I have seen

SCSI storage controller: LSI Logic / Symbios Logic SAS1068 PCI-X Fusion-MPT SAS (rev 01)

And then it presents a list of drivers, I have tried some of them but they did not work.

How can I proceed?

Extra info:

Dell server BIOS Revision 1.5.1

Dell SAS 5 Host Bus Adapter BIOS
MPTBIOS- (2006 12.22)
Copyright 2000-2006 LSI Logic Corp.
  • From Controller-BIOS, do you see the virtual disk? – lg. Aug 17 '10 at 10:35
  • 1
    I tried both general BIOS settings (F2) and SAS Configuration Utility (Ctrl+C) but could not see "virtual disk" related settings. Also looked at the Global properties (Alt+N) but the same situation. PS: There's already an old version of Ubuntu on the machine running without problems (7.04 Feisty) and uname -a gives/ Linux IOULIA 2.6.20-17-generic #2 SMP Wed Aug 20 16:47:34 UTC 2008 i686 GNU/Linux – Emre Sevinç Aug 17 '10 at 10:56
  • Sorry, I thought you have a raid controller. – lg. Aug 17 '10 at 11:54
  • I'm having the exact same issue with 11.10. How did you fix it? – 에이바 Oct 23 '11 at 18:50

Try the mptsas module

Try loading the mptsas module, then check your dmesg output for the new disk.

# modprobe mptsas

The mptsas module has been supported from at least 2005 (first commit that I found in linux-scsi mailing list).

Build Your Own

Looks like LSI has official support for RHEL and SLES. None for Debian/Ubuntu out of the box. But You might be able to convert the RPM supplied on the LSI site to a deb, then install the deb.

Or build the source from scratch, I would suggest the LSI README from their official drivers package to start with. They include complete build and install instructions.

Edit: Also ... consider upgrading your firmware for your card and your system before putting the machine into production. If your last version was from 2006 there might be some bug fixes. It's a good idea to update now, rather than latter. I asked a similar SF question along these lines and received some excellent answers: Firmware Best Practices and Update Schedules

  • That is my guess, too. – Nils Oct 27 '11 at 20:29

Some Dell systems, depending on the RAID controller they ship with, don't ship with a default RAID configuration; as a result no SCSI devices are presented to Linux because none have been configured in the RAID controller. Boot the system into the RAID controller firmware interface, and see if any volumes have been configured.

  • I do not have a raid controller and the drives are SAS. – 에이바 Oct 28 '11 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.