I'm trying to upgrade an evaluation instance of SQL Server 2008 to a fully licensed instance of SQL Server 2008 R2. I made it most of the way through the installer, but I'm getting stopped at the Upgrade Rules page - the SQL Server Analysis Services Upgrade Service Functional Check is failing. The specific error I get:

Rule "SQL Server Analysis Services Upgrade Service Functional Check" failed.

The current instance of the SQL Server Analysis Services service cannot be upgraded because the Analysis Services service is disabled or not online. Please start the service and then run the upgrade rules check again.

Simple enough - just need to start the service. Here's where it gets troublesome. When I open Services and go to start the SQL Server Analysis Services (MSSQLSERVER) service, it provides me the following message:

The SQL Server Analysis Services (MSSQLSERVER) service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

Trying from the command line as Administrator yields:

PS C:\Windows\System32> net start MSSQLServerOLAPService

The SQL Server Analysis Services (MSSQLSERVER) service is starting...

The SQL Server Analysis Services (MSSQLSERVER) service could not be started.

The service did not report an error.

More help is available by typing NET HELPMSG 3534.

I've tried changing the logon setting of this service to Administrator, a user with admin privileges, and both the Local System and Network Service accounts - nothing works. In addition, when I look at the service through the SQL Server Configuration Manager (also run as Administrator), attempting to change the logon setting for the service results in the message:

The server threw an exception. [0x80010105]

I have no need for analysis services themselves - all I need is for this one service to be running long enough to do the R2 upgrade, then it can shut down again. Any thoughts on how to get the Analysis Services service running?

Update: Checking the event log, I found an error logged to the Application log from the MSSQLServerOLAPService. It has event ID 0, task category (289), and says:

The service cannot be started: XML parsing failed at line 1, column 4: Unrecognized input signature.

3 Answers 3


The first thing you need to do is establish why isn't the service starting. The SSAS service will log its problems into the system event log, and there is where you need to look. Start EventVwr.exe and check the application log for events reported by SSAS.

The errors are also reported in the error log files, see Analysis Services Configuration - Data Directories for their location.


Clean the system event log and then try to start the analysis service. This has worked for me.



Do you upgrade through automatic updates? If yes, try running the upgrade file manually. You should be able to deselect upgrading the analysis services (or you can uninstall them separately in SQL server setup if you don't need them.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.