I have a wireless network between two buildings that seems to work fine but when I ping across the networks I see an average of about 10% dropped packets (over several days or however long the ping in Windows keeps track). If I ping a machine on the local lan or even google, I get 0% loss over the same time period.

The wireless "bridge" (as I like to call it) is two WAP54GP devices that connect to antennas that are on the roof. MAIN (which is wired to the router that goes to the internet) has a omnidirectional antenna (so that potentially other buildings can connect) and WS (about 500 or so feet away) has a directional antenna that is directed at MAIN.

The AP Mode of MAIN is set as an Access Point that "Allow wireless signal to be repeated by a repeater." And the setting for that is the wireless mac of WS.

The AP Mode of WS is "Wireless Repeater" and is set to the mac of MAIN. I tried turning off the repeater mode and setting up WS as a wireless bridge but that didn't work.

Here are the setting on both routers:

  • Mixed mode B/G
  • Security Mode: PSK (not sure what that is actually . . I thought options were WAP or WPA)
  • Encryption: TKIP
  • Channel 11 (which is an uncrowded channel according to Wifi Analyzer the Android app)
  • Wireless Isolation: off
  • CTS Mode: AUTO
  • Beacon: 100
  • DTMI: 1
  • RTS: 2347
  • Fragmentation: 2346

Any ideas?

  • @ChrisS You should make than an answer so I can accept it! I had a hunch about just setting it to G since, well, even an iPad can't connect to a mixed mode network and it worked! No dropped pings. I also thought that maybe setting it to G-only was sort like setting a switch to use only gigibit instead of auto-negotiate. And thanks for the info on PSK . . the only other option is PSK2 which is probably WPA2 which would be better. There is also "ENT" and "ENT2" and that's another WPA is my guess. – Sheldon McGee Aug 18 '10 at 16:09

First off, there's no reason for you to be using mixed mode in this scenario. Switch to G only on both devices.

Secondly, you'll need to start looking at your SNR ratios on your WAPs. What does the remote one say? What does the local one say? In wireless SNR is really what matters.

Thirdly, I'm not certain why you are using a repeater here. That could explain your poor performance. Sounds like you want a bridge but have configured a basic repeater. All a repeater does is retransmit packets so you will suffer a delay, a big bandwidth hit, and potentially signal loss. You should read up on the difference between a repeater and a bridge.

Lastly, wireless will never be as fast or reliable as wired. So you'll always see some packet loss and extra latency. 10% is pretty high but with the proper setup you may be able to get it below 5% or so. I'd also consider switching to channel 1 or 6. Your little wifi analyzer is blind to a significant amount of noise out there. You may want to move up to enterprise grade WAPs while you're at it. Those Cisco branded Linksys things are really toys. Nice cost savings if they work for you but I would have a spare or two lying around along with exported settings somewhere safe.

  • What are some examples of enterprise grade WAPs? Is the fact that I have no idea how to check the SNR the reason why these consumer grade units aren't the best option? – Sheldon McGee Aug 19 '10 at 4:20

The security modes are WEP or WPA. PSK is a type of WPA, secured with a Pre-Shared Key. It's not the best encryption to use, and wouldn't be terribly hard for a determined hacker to get in; especially with that omni-directional antenna. You should limit the mode to either B or G; pick one and run with it (B will be more robust, but slower). I'd start by getting two good directional antennas and see what your drop rate is then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.