I'm running an Asus P6T V2 Deluxe. It has six SATA ports and supports onboard RAID.

I am using two of those ports for a RAID0 array of 1.5TB Seagate drives using the onboard RAID controller. One of them is giving me SMART warnings and I want to preemptively replace it. I pulled out two other 1.5TB drives from another computer and am ready to use one or both, if necessary.

I can't run any SMART diagnostic software from within Windows because it only sees the hardware RAID-0 array, not each individual drive.

The first thing I tried was a slow sector-by-sector copy using a free tool called EASEUS Disk Copy. Used the bootdisk, copied (took like 16 hours), unplugged the defective drive and plugged the new one in its place. The motherboard didn't recognize the new drive as being part of the known setup, so it did not want to boot.

The second thing I tried was using other software (I forget the name) to copy the partition from within Windows. The first software failed because I had a server operating system. I found another software (I forget the name) which supported a server OS and did a partition copy onto the new drive. This seemed to work and the OS started to boot, but blue screened and started a reboot cycle. I'm assuming the software I was using was no good as it was trying to copy the boot disk while it was in use.

I am looking for recommendations on what software to use to fix my problem without doing a re-install. Everything is backed up but my computer works fine and I'd like to avoid re-installation when possible. However, my system would be back up now if I had just started over on a second RAID array. :)


Are you able to enter a config mode for your onboard RAID? Once you replace the defective drive, the RAID BIOS needs to know that it's ok to use the replacement drive. This is generally done with a 'rebuild' type command that replaces the ID of the old drive with that of the replacement.

I'm being general here deliberately, as you'll want to read up on this and make sure you're using the correct menu commands.

  • Yes, I had taken a look at the configuration module, but the options were very limited. I believe it only had three options: create a new raid configuration, view details of an existing one and delete an existing one. However, I'll investigate further. Aug 18 '10 at 14:44
  • Hopefully there's a manual somewhere documenting how the 'create' can be used to rebuild. Aug 18 '10 at 15:17
  • I double checked, and there is not. However I found the Intel Matrix Storage Manager software, installed it, "Marked drive as spare", rebooted, and now it is "automagically" rebuilding my RAID array. It is odd that it can only mark as spare or rebuild while in Windows and not before booting it, but this appears to be solving my problem. Aug 18 '10 at 15:22
  • Fantastic! I was afraid for a minute there that a RAID controller existed with no ability to swap drives (it's sad that this wouldn't be surprising, huh?) - glad to hear it. Aug 18 '10 at 16:09

Why don't you try booting into in repair mode using the Windows Server Installation disk? If an error pops up saying "Cannot find Installation hard disk" you should use "nLite" and integrate the RAID hardware driver with the installation disk by creating a new iso with "nLite" and then boot up into your system which you should then install the driver into the OS.

  • Not sure I catch where you're going as this isn't a driver issue. Aug 18 '10 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.