We've got a curious problem with one of our Solaris (10, U8) servers. If we have our extra storage array mounted via NFS, the Solaris user logins are exceptionally slow. Unmount the storage device and user logins get real fast again. Anyone ever encounter anything like this before?

I've got other Solaris 10 servers elsewhere with storage arrays mounted the same way that don't have the issue. Those other ones actually are attached to even slower pieces of equipment and should be worse, all else being equal.

I really don't understand why an NFS mount that shouldn't be involved in the login process at all is causing the slowdown.

  • Is DNS working ok? Sometimes if you have mounted something by using DNS name and the first DNS server is not available, things get slow. Though if everything else is working OK, I don't think this is the reason. – Janne Pikkarainen Aug 19 '10 at 13:28
  • DNS is working nice and fast. The actual mount happens real quick. AFAIK, user logins aren't touching this mount anyways. – Brian Knoblauch Aug 19 '10 at 13:52

The login process might spend a lot of time in the /usr/sbin/quota check if quotas are enabled on the NFS filesystems.

| improve this answer | |
  • 1
    Solaris will always wait for the remote quota check call to return on login unless you either use the noquota mount option, or touch $HOME/.hushlogin - see /etc/profile. – alanc Aug 19 '10 at 20:17
  • Aha! Excellent suggestion. I'll check that as soon as I get a chance. I suspect you're right... This storage system has quotas on it and the others do not! – Brian Knoblauch Aug 20 '10 at 12:54

Check the PATH environment variable. Odds are, the users' PATH includes directories that you are NFS mounting. So they're probably getting checked for executables, configuration scripts, etc. When nothing is mounted, those directories will be local, and will obviously go quickly. But once you've NFS mounted them, it will be delayed. This will be compounded if you have multiple such directories in the PATH.

--Christopher Karel

| improve this answer | |
  • A good thought, but that's not it in this case. We're mounting to a completely new place, not in anyone's path. – Brian Knoblauch Aug 19 '10 at 13:51

correct as said by – alanc Aug 19 '10 at

Had the exact same issue with servers NFS Share over different Vlans and noquota option resolved it, I have tried sharing a nfs mount point over the same Vlan and the problem did not appear."" Solaris will always wait for the remote quota check call to return on login unless you either use the noquota mount option!!!!!!!""

It is necessary to add a noquota option in the /etc/vfstab in order to let the system know quota doesn't need to be checked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.