The shift key won't work through VNC to my Ubuntu server except for the characters ÅÄÖ. I'm using UTF-8 and sv_SE as locale. I find no options or settings that I can set nor do I find any information on google about people with similar problems.

Anyone here that might know what's wrong? Connecting to Ubuntu 10.04 from Windows 7


The problem seemed to be with x11vnc, the server that I run.

To enable the shift-keys I used the argument -nomodtweak when starting x11vnc. This enabled the shift-keys for me!

  • Zolomon, I am still having the issue. I have x11vnc listed in the Startup Applications with this command line (found in my searches for starting x11vnc at startup ). gnome-terminal -x x11vnc -nomodtweak -rfbauth /etc/x11vnc.pass -display :0 -forever -solid red Any changes you can see that would help enable the shift key that I haven't included? Perhaps the -xkb flag. Thanks! – user67848 Jan 22 '11 at 22:18
  • @Chronos: I have a swedish keyboard layout, that might be the cause of our differences? – Zolomon Jan 23 '11 at 9:10
  • +1 : Great! I was having the same problem... actually in my case only the () were working... the rest, as if it didn't have the shift key. My Keyb is Japanese, but the strange thing is that when I set the keyb layout to English-Latin (with a very different layout) most of the key worked correctly (even the shift key), but still was not perfect. Adding that option to x11vnc (and using Japanese layout) made my problems disappear. Thank you! – lepe Mar 3 '11 at 3:35

From reports on the web, it does appear that x11vnc has shift-related server-side problems, but various VNC clients DO also have their own similar client-side bugs. I am on Ubuntu 14.04.3 LTS, using VNC to connect to a Windows 7 machine. In my case, the shift key works normally when typing, but shift-click or ctrl-click with the mouse did not work at all!

Switching to gvncviewer (version 0.5.3-0ubuntu2) fixed the problem for me. The shift-click bug still exists in xtightvncviewer (1.3.9-6.4ubuntu1) and xvnc4viewer (4.1.1+xorg4.3.0-37ubuntu5.0.2).

Some additional bug reports and discussions of the problem:

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.