3

We have a Linux box running SUSE Linux Enterprise Server 11 (x86_64).

recently, we found many "Link is Down/Up" in /var/log/messages

and the Link was actually Disconnected and Reconnected many times,

this make this server almost unusable (ping test has a packet loss of 20%)

How can i address such an issues? any suggestion is welcome, thanks very much.

# lspci |grep -i eth
04:00.0 Ethernet controller: Intel Corporation 80003ES2LAN Gigabit Ethernet Controller (Copper) (rev 01)
04:00.1 Ethernet controller: Intel Corporation 80003ES2LAN Gigabit Ethernet Controller (Copper) (rev 01)

# uname -a
Linux mybox 2.6.27.19-5-default #1 SMP 2009-02-28 04:40:21 +0100 x86_64 x86_64 x86_64 GNU/Linux

# ethtool eth1
Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbag
        Wake-on: g
        Current message level: 0x00000001 (1)
        Link detected: yes
3

Have you checked your switch and ethernet cable, that is most likely the issue.

| improve this answer | |
3

Yeah, definitely sounds like a hardware error. It could be your NIC, your cable or the switch port. Easiest would be the swap the network port on the switch first, then swap the cable, then finally swap the NIC to isolate the issue.

| improve this answer | |
  • I'd replace the cables first; otherwise you'll always have a switchport on the switch that you'll be suspicious of. – Mitch Miller Sep 7 '10 at 4:37
1

Try turning autonegotiation off.

| improve this answer | |
0

You could try to disable NetworkManager completely. It was my case with 2 network cards and same behaviour. First look if it's running:

nmcli device status

and stop it:

systemctl stop NetworkManager

then, look if there it is a service still running:

systemctl list-unit-files | grep NetworkManager

and proceed to disable/stop it:

systemctl disable NetworkManager
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.