0

When using Outlook 2007 connecting to our Exchange server through the public URL, I get the following error: There is a problem with the proxy server's security certicate. The name on the security certificate is invalid or does not match the name of the target site mail.contosco.com.

Outlook is unable to connect to the proxy server. (Error Code 0)

(The message has our company URL instead of Contosco) We've set this up with self-signed cert and the system works remotely for all of our remote computers except this one. This one is different in that it is the first Vista 64bit to be tested for deployment. It's Vista SP2 also. Our mail server is set up FQN of mail.contosco.local.

I've made sure if I visit the website mail.contosco.com using a browser, that the certificate is considered trusted since I have installed the signing cert into cert list.

If I turn off the "Only connect to proxy servers that have this principal name in their certificate:" which contains msstd: mail.contosco.com, then it works. I'm convinced all the other settings are the same as our other Vista Outlook 2007 machines which all work. Any ideas?

0

This error can arise when there's a mismatch between the common name of the certificate and the "only connect to proxy servers" setting. Check out this article for more information on troubleshooting.

  • -1 for a dead link. In the future, please paste the relevant portion of linked websites into your answers so that your answer remains relevant if the link dies. – Thomas Apr 24 at 23:22
0

I had the same issue when I tried to use Outlook 2010 using VPN. after trying many solutions I figured out the solution. Under Exchange proxy settings, check if the checkbox is selected for "on slow network, connect using HTTP first". If yes, uncheck that and restart the outlook. It worked for me & i hope it works for you too.

0

This error can also occur if you've recently enabled TLS 1.2 on an on-premises Exchange server and you have clients running Outlook on Windows 7. Windows 7 uses TLS 1.0 by default and will not use TLS 1.2 unless it is explicitly enabled. Depending on what protocols & cypher suites are enabled in Windows 7, you can get this error because Outlook is unable to recognize the certificate or encrypt/decrypt the connection with Exchange.

This can be resolved by creating the following registry keys to make TLS 1.2 the default in Windows 7:

64 bit Windows: HKLM\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp

32 bit Windows: HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp

  • New: REGDWORD
  • Name: DefaultSecureProtocols
  • Value: 0x00000800

I also recommend running IISCRYPTO to ensure that all of the appropriate cypher suites, protocols, hashes, etc are enabled and that insecure protocols are disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.