I'm trying to map TCP/IP printer connections to my users using GPOs.

I set up the GPO to map 3 different printer connections but it only maps the Printer 1 (the one that's set up as the default printer in the GPO).

To troubleshoot I try attaching a different GPO to the OU (same printers, different one set as default) and it just maps Printer 1 and sets it as default again. I've even tried setting the maps in the Default Domain policy and it still just maps Printer 1 and sets it as default on my computer. I've tried Update, Create and Replace with the same result each time.

Is there some setting getting stuck somewhere that I have to clear in order to get the GPO to map the printers to users correctly??


This was a case of thinking of too many things at the same time. I was messing with the Print and Document Services role about a week ago and inadvertently deleted the printers that I was trying to map. When the GPO tried to find the path \\domain controller\printer to install the driver, it didn't find it and wouldn't map the printer. I'm going to have to make up a checklist here...

  • in one hour lol – blsub6 Aug 24 '10 at 23:17

You said these are TCP/IP printers. Are you mapping them in the Computer Configuration section or the User Configuration section. I could've sworn I read somewhere that TCP/IP printers don't work properly when set from the Computer Configuration.

So if they are, try moving them to the User Configuration and see if that fixes it. You'll want to enable group policy loopback processing so the user configuration gets applied to the computer regardless of which user logs in.

  • The printers are set up in the user configuration section – blsub6 Aug 23 '10 at 6:47

Also, if anyone else was having problems with this, I've found another thing that may prevent TCP/IP printers from mapping correctly.

A user cannot add a printer to the computer they're on if they're not an administrator on that computer. When trying to add the printer manually, they will be asked for the username and password of an administrator. When the GPO is adding the printer on login, it cannot ask for an administrator account so it just errors out while trying to add the printer.

The Point and Print Restrictions GP under Computer>Policies>Administrative Templates>Printers is your ticket to solving this problem. Set the When installing drivers for a new connection: and the When updating drivers for an existing connection: settings to Do not show warning or elevation prompt and it will install the printers just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.