6

I have a LAMP box running Ubuntu, Apache 2 and PHP5 with Slicehost. I'm a bit new to all this sysadmin stuff (I'm primarily a web developer).

I need to use the IMAP functions in PHP, but they don't seem to be enabled according to phpinfo(). How do I enable them?

All of the information I can find on the net says I need to recompile PHP to add it, but I don't have a clue how to do that.

Any advice would be most appreciated. Thanks.

3 Answers 3

12

Well, that depends on the distribution your LAMP server is running on. For example with Debian you can install the PHP5 IMAP module straight from the package manager with command apt-get install php5-imap.

4
  • I tried this, but the IMAP functions still don't show up in the php.ini (even after rebooting Apache and the whole server). I played with a LAMP box a few years back with the original PHP and Apache and remember having to open php.ini and uncomment a line to activate a module - I can't see any sign of that now though. Commented Aug 23, 2010 at 9:47
  • What extensions are listed in php.ini or other ini files? Is there somewhere a line like extension=imap.so? If not, just add it. Commented Aug 23, 2010 at 9:56
  • I re-performed your original suggestion, rebooted apache and it's now working - I must have cocked something up the first time. Thanks! Commented Aug 23, 2010 at 10:28
  • 1
    It's not enough to install it. You have to enable it as @JohnSimmonds mentionned.
    – ychaouche
    Commented Sep 3, 2015 at 9:25
10

Carry out the following:

apt-get install php5-imap

However it's not enabled by default so enable it with:

php5enmod imap

Then bounce apache:

service apache2 restart

Done.

1
  • 1
    Yes, after enabling php module its working like a charm
    – Sabbir
    Commented Mar 25, 2015 at 5:31
2

Check the PHP version:

$ php -v

Suppose shows 7.0.32. So your FastCGI Process Manager(fpm) tool version is 7.0

Now install IMAP ENABLE and ENJOY!! Follow below commands.

# sudo apt-get install php7.0-imap
# phpenmod imap

Restart & Enable service:

# sudo systemctl restart php7.0-fpm
# sudo systemctl enable php7.0-fpm

Check now.. IMAP is enabled!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .