I am having trouble with the server I'm running my trac on. I accidentally had the nightly back up going to the internal hard drive instead of the external. So it filled up, I erased the new files, deleted everything, and rebooted. I'm still getting this error when I try to connect to trac:

OperationalError: (2002, "Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)")

I've tried stopping and starting mysql. I'm assuming this is a mysql problem and not a trac problem since "$ mysql -u -root -p" returns the same problem. I'd like to reemphasize that this was working before so my config files should be fine. Any thoughts?


The mysql server is not running, take a look at the log files to determine what is the issue

  • Okay, fixed it. First off my log was /var/log/mysql/error.log while /var/log/mysql.log and mysql.err were blank. The error was that the plugin FEDERATED was disabled. So I started with "mysqld -u root --federated" – chriscauley Aug 23 '10 at 16:29

The location where the MySQL named pipe is created can be specified in the my.cnf with socket= or via the --socket flag on server start up.

If your socket is not located in /var/run/mysqld/mysqld.sock, which is the location that was specified for the client when MySQL was compiled, you can specify an alternate location with the -S flag.

Otherwise, if skip-networking is not specified in your my.cnf, you can connect using TCP/IP instead of the named pipe by using the -h flag and then the IP address with the MySQL client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.