1

I have a CRON script that emails daily using mutt.

This script has begun to fail, and I now get an email from cron stating:

Can't dotlock /root/sent.

Couldn't lock /root/sent

Could not send the message.

The wierd thing is that I get this email from cron fine, but mutt can't send email. The cron job is run by root, so I don't think this is a permissions issue.

Can anyone shed some light on this?

  • cron reports are sent using sendmail by default, so unless you've changed that, it's still the same. – Chris S Aug 23 '10 at 20:06
2

Is there a /root/sent file/directory/link/other existent ? Is there an other process which take the lock for a while ? Check with lsof -n | grep /root/sent. The rights are good on this file ?

  • 1
    There was a /root/sent.lock file, I deleted this file and it worked! – Josiah Aug 25 '10 at 20:45
  • Sorry for necro but in my case i have no /root/sent, no /root/sent.lock, lsof reports no /root/sent* in use, and there are no other mutt processes active either ... I'm still getting this message. I'm stumped. Any other ideas? – Normadize Feb 4 '18 at 0:14
  • What is your user ? Is it root or the home dir is bad defined ? Check if you can read and write to the /root dir. Check if the partition is read-only. – Dom Feb 4 '18 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.