I'm running Plesk 8.6.0:

I have an SSL cert installed through Plesk's admin interface. But I have a bit of an issue: When I enabled SSL for the site, and selected my cert, then restart httpd, Plesk defaults to using my self-signed default certificate.

Conversely, when I disable SSL support for the domain, all of a sudden Plesk is using my new SSL certificate. Unfortunately, when I try to view any folder on the site (mydomain.tld/folder) I'm simply met with a 404 (with files placed both in httpdocs and httpsdocs). I switch SSL support back on, and Plesk defaults back to the default self-signed cert and I can then view the folders that were not previously accessible.

Any ideas?

One further note: I tried following http://kb.parallels.com/en/939 . Once I tried to restart httpd with the edited ssl.conf file, I received an httpd could not start error. I restored the original ssl.conf file, and still received the could not start error. So as of now, I am running without an ssl.conf file.

The following is the error I receive when I attempt to reintroduce ssl.conf:

Starting httpd: [Mon Aug 23 15:45:40 2010] [warn] module ssl_module is already loaded, skipping
(98)Address already in use: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs

This might not be the answer to your question, but I've found that if you add an SSL certificate to Plesk under the Domains -> Domain Name -> SSL Certificates it doesn't work as expected.

Instead try going to Settings -> SSL Certificates (or Home -> SSL Certificates, I'm not sure which) and adding it there. Then go to (Home or Settings)->IP Addresses, select the IP address used to host this particular domain, and set the default SSL certificate to that one (make sure you delete it from the other location). This works because you can only (with most browsers/systems) have one SSL per IP address anyway so it's equivalent.

  • I originally installed on the server, and then for the domain, and then back to the server and none of those attempts had it functioning correctly. The domain does have an exclusive IP. – hztetra Aug 24 '10 at 14:42

See my answer to mac's question here - it may be relevant (basically sometimes /etc/httpd/conf.d/ssl.conf overrides the Plesk configuration).