1

My newly rebuilt Windows Server 2003 doesn't automatically assign drive letters to external usb devices.

I have to manually open the Disk Management Console and assign it a drive letter every time. It does this with two different drives in all USB ports.

I have been doing some reading and I don't have any network drives, I have also already tried USBDLM and it doesn't seem to have made any difference.

Specs: ProLiant ML150 G5 with Windows 2003 Enterprise and all updates installed.

Any ideas on what I can try to resolve this problem would be greatly appreciated.

Chris

1

Open command prompt:

C:\>diskpart
diskpart>automount          -tell us if automount is enabled
diskpart>automount enable   -enable automatic drive letter assignment if it is not on
diskpart>automount scrub    -remove old automatic drive letter assignments
diskpart>exit
C:\>exit

reboot windows :)

| improve this answer | |
  • Thanks Garret, I will try it sometime this week and let you know how it goes. – Chris Aug 31 '10 at 1:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.