I have a Zoom X5 ADSL modem/router and a DI-524 router.

I needed to turn the Zoom X5 into a modem only and use the DI-524 for router functions (DHCP Server and NAT).

What drove this configuration is that when I signed onto XBOX Live with only the Zoom X5, log-in would take forever and then every once and a while it would lose connection XBOX Live.

I then tried doing port forwarding by manually entering NAT rules that satisfied the port forwarding. This only caused STRICT NAT (symmetric NAT) settings according to the XBOX Live Network Test.

I then configured the Zoom X5 to full bridging function (turned off DHCP server, Nat Functions, and LAN settings). Connected the DI-524 to the Zoom X5.

Zoom X5 (LAN1 Port) ------> DI-524 (WAN Port) Computer (NIC) -------> DI-524 (LAN1)

Shut off DI-524. Rebooted Zoom X5. After reboot of Zoom X5, I turned on DI-524.

After WAN Interface indicator was constantly on, tried internet with IE 7. No connection.

Tried ping well known ip address on internet. No response.

Logged into web interface of DI-524. Looked at status of WAN. It showed "DHCP Client Not Connected".

Reconfigured hardware:

Zoom X5 (LAN1 Port) ----> Computer (NIC)

Repaired Local Area Connection Status in Windows XP.

No Problems with getting public IP address. Good internet connection.

Reconfigured hardware:

Zoom X5 (LAN1 Port) ------> DI-524 (WAN Port) Computer (NIC) -------> DI-524 (LAN1)

Logged into web interface of DI-524. Changed WAN configuration with the MAC address of the computer's NIC card. Did a reboot on the DI-524. All is good.

No why did the ISP (Verizon) not accept the DI=524's MAC address, but accepted the computer's NIC card MAC Address?

As of now the present configuration has been up for two days.

  • Ummm.... checking the FAQ, this seems off-topic. – derobert Jun 2 '09 at 5:04

You are likely running into problems because your Zoom X5 is still acting as a router (even with those features disabled). You should look online for instructions for setting the Zoom X5 in "Bridge Mode" which will cause it to act only as a DSL Modem. This will allow your DI-524 to handle the PPPoE connection as a router and everything should work as you expect.

This link may help: http://my.ruralnetwork.net/tech/setup/dsl_setup_zoom_5554A/zoom5554a_setup11.htm

As for why the MAC address worked, often DSL providers will filter on the MAC address of their DSL modem. In your case, Verizon may have accepted also your PC MAC address after you configured it also for PPPoE. My guess is that changing the MAC address on your DI-524 had little to do with the connection working. You're probably still going to have issues because you're essentially placing a router behind a router. Your best option is to change the Zoom X5 to bridge mode and let your DI-524 be the router.

  • I tried the MAC Address of the ZOOM X5. I got the DHCP Client to connect but no internet. If the modem was still acting as a router and the LAN interface was off how would it be able to translate? The ISP is not PPPoE but is dynamic. Oh and the documentation for Zoom is pretty piss-poor. The instructions you linked only put it into bridge and shut off the DHCP services. I also shut off NAT and the LAN Interface (External DHCP). – Gutzofter Jun 2 '09 at 4:32
  • Did you try those instructions? Perhaps you're turning off too many services. Shutting off the LAN port seems incorrect as you'll need that port to connect to the DI-524. – Kevin Kuphal Jun 2 '09 at 4:36
  • Yep. I mis-spoke instead of turning off the LAN interface, you have the choice of manual/external/internal. I set it for external. – Gutzofter Jun 2 '09 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.