I've just brought up a new installation of SQL Server 2008. I installed the default instance as well as one named instance.

I'm having a problem connecting to the named instance from anywhere besides the server itself with any user besides 'sa'.

I am running in mixed mode. I have a login/user that has a known username. Using that user/login, I can properly connect when directly on the server.

When I attempt to login from anywhere else, I recieve a "Login failed for user ''", with Error 18456. In the log file in the server, I see a reason that doesn't seem to help: "Reason: Could not find a login matching the name provided.". However, that user/login DOES exist, as I can use it locally.

There are no further details about the error. Where can I start to find something to help me with this? I've tried deleting and recreating the user, as well as just creating a new one from scratch--same result, locally fine, remotely an error.

EDIT: Partially Resolved.

I'm now passed the base issue--the clients were trying to connect via the default instance. I don't know why. So, once proper ports were opened in the firewall, and a static port assigned to the named instance, I can now connect--BUT ONLY if I specify the connection as Server,Port. SQLBrowser is apparently not helping/working in this case. I've verified it IS running, and done a stop/restart after my config changes, but no difference yet.

  • In phrase "When I attempt to login from anywhere else", what is I? Webapp, SSMS? – Gennady Vanin Геннадий Ванин Aug 28 '10 at 9:34
  • Both :) SSMS from a remote machine, or any application on a remote machine. – reallyJim Aug 30 '10 at 1:13
  • If you create another SQL login on the named instance, does that work? – Richard Aug 30 '10 at 11:33
  • Nope, same issue. – reallyJim Aug 30 '10 at 14:33
  • Now... you can specify the server\port you can connect that way, but not with server\name is that correct? – Dave Holland Aug 31 '10 at 2:41

Based on the fact that the connections work when you do Server,Port I think your issue is related to not having the SQL Browser port opened on the firewall (1434). Honestly, though, I think you're safer if you hard-code the ports.

  • @reallyJim: Make sure that port 1434 us an UDP port and not a TCP. Also try to use portqryui tool from Microsoft that makes it very easy to query SQL Browser and check its response. – Robert Koritnik Feb 13 '12 at 8:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.