I'm trying to connect to my SQL Server on my VPS but i can't get this to work.

  • I have enabled the TCP/IP protocol on SQL.
  • I also have the SQL Server and SQL Browser service running as a network service.
  • I turned off my firewall on my server and on the client (I won't keep it like this it's just for testing).

After doing all this it still doesn't work.

It seems that i can't reach port 1433 or 1434 either:

C:\>telnet myserver 1433
Connecting To mrsoundless.com...Could not open connection to the host, on port 1
434: Connect failed

C:\>telnet myserver 1434
Connecting To mrsoundless.com...Could not open connection to the host, on port 1
433: Connect failed

Could someone explain why this could be happening?

  • Note1: I'm new to MSSQL.
  • Note2: The server is a VPS for personal use.
  • Note3: I use SSMS to try to connect to SQL Server 2008 Express

Sounds to me like your VPS host has a firewall or other filtering device sitting in between you and your server. Give them a call and see if this is the case and if so see if they can change the configuration to allow connections through to your VPS.


After you change connection settings, such as enabling TCP/IP and listening on a static port, you need to restart the MSSQL service for that instance for those changes to take effect.

  • I did. I even restarted the server to make sure the right service was restarted! – MrSoundless Aug 29 '10 at 1:40

Is it listening on port 1433? Try running from the command prompt:
netstat -ano
If it doesn't say TCP LISTENING in there it's not listening. If it does, try connecting to localhost instead of myserver - if that works, you sir have yourself a firewall issue. Check Windows Firewall then phone your provider.

  • I used portqry to check if the ports are listening. It seems that 1434 is listening. When I run portqry from the client it says it's filtered. 1433 is not listening at all which I think is weird because the port is set to 1433 by default in the SQL Configuration Manager. Also, as stated in the main post, both firewalls on server + client are turned off (unless you're talking about hardware firewalls, not sure about that...) – MrSoundless Aug 29 '10 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.