I'm having a problem with a couple 10GB NICs, one in particular in Windows 7 x64 that always thinks the cable is missing. The drivers for the NIC are current, downloaded from Intel- it's settings are defaults, although I did set an IP address once to see if it helped, and it didn't.

The cards I'm using are both the same, hybrid Dell / Intel. Dell Part Numbers T645H, Intel Models 82598.

The cable I'm using between the cards is a Cisco SFP-H10GB-CU3M.

I found this information helpful from Intel.com regarding which SFP+ cables will work with that card: www.intel.com/support/network/adapter/10gbe/afdadualserver/sb/CS-029097.htm

It mentions the cables have to comply with certain specifications to function properly, and according to the product page for the cable I have, they match and should be working.

Cisco cable details: www.cisco.com/en/US/prod/collateral/modules/ps5455/data_sheet_c78-455693.html

I saw this relatively cheap switch on eBay, (Item number: 370424159424) and considered buying that to see if the problem has to do with the cable not being a 'crossover' cable per se.

I'm hesitant to do that since the description mentions it having SFP ports, rather than SFP+ ports, and I'm not sure of the ramifications of mixing these, since I'm early in the learning curve of 10GB.

I'm not certain what to do next, I don't want to have to buy a switch to go between, plus another cable- it seems very expensive just to make a single fast link.

Thanks in advance, your feedback is appreciated.


On the flip-side of what ramruma has presented, have you tried hard coding the line settings on at least one side - just in case it is an auto-negotiation incompatibility issue?

  • When I look at the 'Link Speed' tab on the Windows side, the speed selection drop-down is greyed out and below it says: 'Some Intel® 10GbE adapters can operate at both 10Gbps and 1Gbps. The link speed is dependent on the adapter’s link partner. You cannot change the speed setting for these adapters.' The Debian side uses /etc/network/interfaces for settings, I'll look into how that can be defined there- thanks. – NginUS Aug 31 '10 at 2:22

The condition was finally resolved after a lengthy tech support process with Dell where it was confirmed that while these cards' part numbers were officially discontinued, the actual design of the card was the same as another that was currently available. Something to do with their supply chain requiring part number changes if I remember correctly.

So cables were ordered which were known to be compatible with the equivalent part, and by the time they arrived the network layout had changed such that linux 2.6.32-2 would be providing the driver rather than Windows, and now all works flawlessly.

I didn't take the time to see if the original cable still worked with the new OS- it was discarded.

And I wasn't able to replace the OS with a Windows installation even temporarily to see if the new cables worked with those drivers, I'm just glad it works in linux.


You should have both ends (Windows and the switch) set to autonegotiate.

  • There's cases where this doesn't work, though it should be tried first. – Chris S Aug 30 '10 at 14:46
  • It's not looking like that'll be an option on these. Speed drop-down is greyed out accompanied by a statement that 'You cannot change the speed setting for these adapters.'. – NginUS Aug 31 '10 at 2:25

10 Gb is a pretty high bandwidth. If you trust your cables, that are not cross cables, then it could be that the switch cannot accommodate the speed / the auto-negotiation protocol from the Windows NIC.

I would try, on Windows, to start by forcing the speed to 10 Mb, then - if it works - increase gradually.

You may also have a defective port on the switch, or a wrong setting - try to change the switch port.

Also, if you can access your switch via serial or another computer, and if a web (...) interface is available, try to see and edit the settings, view the logs.

  • 1
    Most 10GbE cards do not go slower then 1GbE, including this one. Also, the copper SPF+ cables don't come in non-crossover; SPF isn't like a C8P8 jack; the TX always goes to RX (and vice-versa). The defective port is a definite possibility (though I don't think he's using a switch), as are incorrect settings. – Chris S Aug 30 '10 at 14:56
  • There's no switch yet. One vendor's refunding the expensive Cisco cable, since it's specs aren't both of what the card wants. The card's compatibility statement uses the word 'and' between the SFF numbers, while the cable only adheres to the lower number: "connections support any SFP+ passive direct attach copper cable that complies with the SFF-8431 v4.1 and SFF-8472 v10.4 specifications." Will call Dell & order a supported cable direct rather than selecting one on my own again. These cards are discontinued, so no guarantees. – NginUS Aug 31 '10 at 2:22

It might be something simple... or quite complex. Simple solutions include: unable to auto-negotiate speed... so force select port speed. You might have the tx fiber going to tx on the other side... try reversing them. (you need tx going to rx and rx going to tx) Are the optic cable ends dirty? a spec of dust can cause you a long list of headaches.

More complex problems & solutions... Make sure that both cards are using the same light frequency & signaling scheme. i.e. R, SR, LR, LRM, ER, ZR, LX4, (don't mix & match... it won't work) and also make sure that you are using cables that meet with your requirements. i.e. multi-mode vs single-mode. Some cards require one or the other due to cheaper lasers & such. It also never hurts to get in touch with your vendor & find out what they would recommend.

  • He's using a copper cable, fiber settings aren't going to get very far with that. – Chris S Aug 30 '10 at 14:45
  • I have located the proper support number to reach Dell for an officially matched cable. One day far in the future I'll look at this post and my optical troubles of the day will have been solved all this time ago by this post here, thanks. That or someone else will happen across it and be helped. – NginUS Aug 31 '10 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.