0

I have a Fedora FTP server that uses VSFTPD. I wanted to know how I could allow the users to upload directories and make directories.

Thanks in advance.

1

Make sure you have

write_enable=yes

in your vsftpd.conf. It's off by default so by default your FTP site is a read-only site.

1

Check your SELINUX settings. VSFTPD will allow this, it is probably SELINUX blocking this.

Here is a working config from RHEL5.

It will chroot users into their home directory and allow file/folder creation assuming they can authenticate by methods enabled in the systems pam configuration.

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=0072
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
listen=YES
pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
ascii_upload_enable=YES
ascii_download_enable=YES
ftpd_banner=FTP server
ls_recurse_enable=YES
chroot_local_user=YES
pasv_min_port=30000
pasv_max_port=60000
force_dot_files=YES
use_localtime=YES

With the above config you can then use /etc/hosts.allow to lock down vsftpd to certain remote users or allow ALL to connect.

1

When you say "the users", did you mean the local system users? If so, you need the "local_enable line. If you instead meant "the VSFTPD users", ignore it.

# Uncomment this to allow local users to log in.
local_enable=YES

# Uncomment this to enable any form of FTP write command.
write_enable=YES
  • local_enable=YES is not related to the question – gelraen Jan 21 '11 at 17:54
  • @gelraen: That's a matter of interpretation. But OK, I've edited my answer to clarify. – Teddy Jan 23 '11 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.