I have a Windows Server 2008 R2 with RemoteApp service installed. I have published a certain application and created an RDP file for it. After the user has finished using this remote application and closes the window there's a "grace period" of 20 seconds before the session becomes "disconnected". My question is can I control this grace period? make it more then 20 seconds.

Tried so far every possible option in GPO - didn't work. It seems I can adjust how much time it takes to logoff a disconnected session and such... but none of these options control the 20 seconds period.

I thank you for taking the time to read my question.


As far as I know, you cannot control this 20s setting.
On the other hand if what you actually want is to keep the application running on the server so the user can quickly reconnect to it and carry-on where they left off, then it is possible.

The whole process of RemoteApp disconnection is described on the Remote Desktop team blog in this article: Terminal Services RemoteApp™ Session Termination Logic.

There is a setting in the Group Policies on the server that controls how RemoteApp applications should behave when they are disconnected.
Basically, a log off is performed by default when you close a RemoteApp (after the 20s grace has elapsed), but you can change this setting to something else.

You will find the settings on the server here (for Win2008):

Local group Policies (run gpedit.msc)
  > Computer Configuration
    > Administrative Templates
      > Windows Components
        > Remote Desktop Services
          > Remote Desktop Session Host 
            > Session Time Limits
              > Set time limit for logoff of RemoteApp sessions

Note: make sure you don't override disconnect/log-off settings through the Computer Configuration or User configuration or it won't have any effect as they would have precedence.

  • This is mostly correct, but if the user has closed the application/window, there is no running application to reconnect to! The user can (during the "disconnected" state) reconnect to the same, empty session and restart the application. – Christian Davén Feb 2 '16 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.